aboutsummaryrefslogtreecommitdiffstats
path: root/solar-python/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2021-02-20 12:30:39 +0100
committerMattias Andrée <maandree@kth.se>2021-02-20 12:30:39 +0100
commit91ce6e5c4f74605b272eef58383a6e0b6076056d (patch)
treed3e1384608e1a461cef29b4064162e486f09c84f /solar-python/PKGBUILD
parentUpdate blue (diff)
downloadaur-packages-91ce6e5c4f74605b272eef58383a6e0b6076056d.tar.gz
aur-packages-91ce6e5c4f74605b272eef58383a6e0b6076056d.tar.bz2
aur-packages-91ce6e5c4f74605b272eef58383a6e0b6076056d.tar.xz
Update solar-python
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'solar-python/PKGBUILD')
-rw-r--r--solar-python/PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/solar-python/PKGBUILD b/solar-python/PKGBUILD
index 66549d6..e128634 100644
--- a/solar-python/PKGBUILD
+++ b/solar-python/PKGBUILD
@@ -1,27 +1,26 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=solar-python
-pkgver=2.5
+pkgver=2.5.2
pkgrel=1
pkgdesc="Solar data calculation and prediction library for Python"
arch=(any)
url="https://github.com/maandree/solar-python"
-license=('AGPL3')
+license=('custom:ISC')
depends=(python3)
makedepends=(make coreutils python3 texinfo)
-install=solar-python.install
source=($url/archive/$pkgver.tar.gz)
-sha256sums=(fb62ee7ddaafae0ee92d00b4b1efdbb01f5c9eb93bc8e7007379adefed7899a4)
+sha256sums=(6f191d8c1012770a6016146b5c3880388f936d1f85c41e81c0b0ebc379785722)
build() {
cd "$srcdir/$pkgname-$pkgver"
- make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)"
+ make PREFIX=/usr PY_MAJOR=3 PY_MINOR="$(python3 -V | cut -d ' ' -f 2 | cut -d . -f 2)"
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)" install DESTDIR="$pkgdir"
+ make PREFIX=/usr PY_MAJOR=3 PY_MINOR="$(python3 -V | cut -d ' ' -f 2 | cut -d . -f 2)" install DESTDIR="$pkgdir"
}