aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--solar-python/PKGBUILD11
-rw-r--r--solar-python/solar-python.install20
2 files changed, 5 insertions, 26 deletions
diff --git a/solar-python/PKGBUILD b/solar-python/PKGBUILD
index 66549d6..e128634 100644
--- a/solar-python/PKGBUILD
+++ b/solar-python/PKGBUILD
@@ -1,27 +1,26 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=solar-python
-pkgver=2.5
+pkgver=2.5.2
pkgrel=1
pkgdesc="Solar data calculation and prediction library for Python"
arch=(any)
url="https://github.com/maandree/solar-python"
-license=('AGPL3')
+license=('custom:ISC')
depends=(python3)
makedepends=(make coreutils python3 texinfo)
-install=solar-python.install
source=($url/archive/$pkgver.tar.gz)
-sha256sums=(fb62ee7ddaafae0ee92d00b4b1efdbb01f5c9eb93bc8e7007379adefed7899a4)
+sha256sums=(6f191d8c1012770a6016146b5c3880388f936d1f85c41e81c0b0ebc379785722)
build() {
cd "$srcdir/$pkgname-$pkgver"
- make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)"
+ make PREFIX=/usr PY_MAJOR=3 PY_MINOR="$(python3 -V | cut -d ' ' -f 2 | cut -d . -f 2)"
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)" install DESTDIR="$pkgdir"
+ make PREFIX=/usr PY_MAJOR=3 PY_MINOR="$(python3 -V | cut -d ' ' -f 2 | cut -d . -f 2)" install DESTDIR="$pkgdir"
}
diff --git a/solar-python/solar-python.install b/solar-python/solar-python.install
deleted file mode 100644
index 0227091..0000000
--- a/solar-python/solar-python.install
+++ /dev/null
@@ -1,20 +0,0 @@
-_file="solar-python"
-
-infodir="usr/share/info"
-file="${_file}.info"
-
-
-post_install() {
- [[ -x "usr/bin/install-info" ]] || return 0
- install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
-}
-
-post_upgrade() {
- post_install "$1"
-}
-
-pre_remove() {
- [[ -x "usr/bin/install-info" ]] || return 0
- install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
-}
-