aboutsummaryrefslogtreecommitdiffstats
path: root/emacs-gtk2/watch
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-11-20 05:48:03 +0100
committerMattias Andrée <maandree@operamail.com>2012-11-20 05:48:03 +0100
commit0a94bb8379ab485b0e58bdbaf9d969362f4b1efc (patch)
treeaba74020aa4ebc05afddcdbbd16151d908ae3417 /emacs-gtk2/watch
parentwatch fix for qtsixa (diff)
downloadaur-packages-0a94bb8379ab485b0e58bdbaf9d969362f4b1efc.tar.gz
aur-packages-0a94bb8379ab485b0e58bdbaf9d969362f4b1efc.tar.bz2
aur-packages-0a94bb8379ab485b0e58bdbaf9d969362f4b1efc.tar.xz
due not notify about a package being unfetchable twice, now that running this is automated.
Signed-off-by: Mattias Andrée <maandree@operamail.com>
Diffstat (limited to 'emacs-gtk2/watch')
-rwxr-xr-xemacs-gtk2/watch4
1 files changed, 3 insertions, 1 deletions
diff --git a/emacs-gtk2/watch b/emacs-gtk2/watch
index 95a07a2..6a52673 100755
--- a/emacs-gtk2/watch
+++ b/emacs-gtk2/watch
@@ -7,6 +7,7 @@ mv 'PKGBUILD?h=packages%2Femacs' PKGBUILD.upstream.new
mv 'emacs.install?h=packages%2Femacs' emacs.install.upstream.new
if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
grep ^pkg < PKGBUILD.upstream.new | md5sum > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
@@ -19,7 +20,8 @@ if [ $? = 0 ]; then
mv emacs.install.upstream.{new,old}
echo 'emacs-gtk2'
fi
-else
+elif [ ! -f unfetchable ]
+ touch unfetchable
echo 'emacs-gtk2 (unfetchable)'
fi