aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xblender-plugin-vectex/watch4
-rwxr-xr-xcedilla/watch4
-rwxr-xr-xdooble/watch4
-rwxr-xr-xemacs-gtk2/watch4
-rwxr-xr-xjavagnutar/watch4
-rwxr-xr-xpony/watch4
-rwxr-xr-xpython2-numpydoc/watch4
-rwxr-xr-xqtsixa/watch4
-rwxr-xr-xrssyl/watch4
-rwxr-xr-xxz-java/watch4
10 files changed, 30 insertions, 10 deletions
diff --git a/blender-plugin-vectex/watch b/blender-plugin-vectex/watch
index 21bc8a0..f1502d2 100755
--- a/blender-plugin-vectex/watch
+++ b/blender-plugin-vectex/watch
@@ -2,6 +2,7 @@
wget http://code.google.com/p/vectex/ >/dev/null 2>/dev/null
if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
grep release < index.html | md5sum > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
@@ -11,7 +12,8 @@ if [ $? = 0 ]; then
echo 'blender-plugin-vectex'
fi
rm index.html
-else
+elif [ ! -f unfetchable ]
+ touch unfetchable
echo 'blender-plugin-vectex (unfetchable)'
fi
diff --git a/cedilla/watch b/cedilla/watch
index daab691..f319765 100755
--- a/cedilla/watch
+++ b/cedilla/watch
@@ -2,6 +2,7 @@
wget 'http://www.pps.univ-paris-diderot.fr/~jch/software/cedilla/NEWS.text' >/dev/null 2>/dev/null
if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
md5sum < NEWS.text > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
@@ -11,7 +12,8 @@ if [ $? = 0 ]; then
echo 'cedilla'
fi
rm NEWS.text
-else
+elif [ ! -f unfetchable ]
+ touch unfetchable
echo 'cedilla (unfetchable)'
fi
diff --git a/dooble/watch b/dooble/watch
index 4547d52..a1e2ddf 100755
--- a/dooble/watch
+++ b/dooble/watch
@@ -2,6 +2,7 @@
wget http://dooble.sourceforge.net/ >/dev/null 2>/dev/null
if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
grep Release < index.html | md5sum > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
@@ -11,7 +12,8 @@ if [ $? = 0 ]; then
echo 'dooble'
fi
rm index.html
-else
+elif [ ! -f unfetchable ]
+ touch unfetchable
echo 'dooble (unfetchable)'
fi
diff --git a/emacs-gtk2/watch b/emacs-gtk2/watch
index 95a07a2..6a52673 100755
--- a/emacs-gtk2/watch
+++ b/emacs-gtk2/watch
@@ -7,6 +7,7 @@ mv 'PKGBUILD?h=packages%2Femacs' PKGBUILD.upstream.new
mv 'emacs.install?h=packages%2Femacs' emacs.install.upstream.new
if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
grep ^pkg < PKGBUILD.upstream.new | md5sum > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
@@ -19,7 +20,8 @@ if [ $? = 0 ]; then
mv emacs.install.upstream.{new,old}
echo 'emacs-gtk2'
fi
-else
+elif [ ! -f unfetchable ]
+ touch unfetchable
echo 'emacs-gtk2 (unfetchable)'
fi
diff --git a/javagnutar/watch b/javagnutar/watch
index 1a82980..d8790df 100755
--- a/javagnutar/watch
+++ b/javagnutar/watch
@@ -2,6 +2,7 @@
wget http://code.google.com/p/javagnutar/ >/dev/null 2>/dev/null
if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
grep \\.zip < index.html | md5sum > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
@@ -11,7 +12,8 @@ if [ $? = 0 ]; then
echo 'javagnutar'
fi
rm index.html
-else
+elif [ ! -f unfetchable ]
+ touch unfetchable
echo 'javagnutar (unfetchable)'
fi
diff --git a/pony/watch b/pony/watch
index e7e4123..c45ca4b 100755
--- a/pony/watch
+++ b/pony/watch
@@ -2,6 +2,7 @@
wget http://hackage.haskell.org/package/pony >/dev/null 2>/dev/null
if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
md5sum < pony > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
@@ -11,7 +12,8 @@ if [ $? = 0 ]; then
echo 'pony'
fi
rm pony
-else
+elif [ ! -f unfetchable ]
+ touch unfetchable
echo 'pony (unfetchable)'
fi
diff --git a/python2-numpydoc/watch b/python2-numpydoc/watch
index a7dace9..e10f310 100755
--- a/python2-numpydoc/watch
+++ b/python2-numpydoc/watch
@@ -2,6 +2,7 @@
wget http://pypi.python.org/packages/source/n/numpydoc/ >/dev/null 2>/dev/null
if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
grep numpydoc- < index.html | md5sum > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
@@ -11,7 +12,8 @@ if [ $? = 0 ]; then
echo 'python2-numpydoc'
fi
rm index.html
-else
+elif [ ! -f unfetchable ]
+ touch unfetchable
echo 'python2-numpydoc (unfetchable)'
fi
diff --git a/qtsixa/watch b/qtsixa/watch
index 332de0c..cb8648c 100755
--- a/qtsixa/watch
+++ b/qtsixa/watch
@@ -2,6 +2,7 @@
wget http://sourceforge.net/projects/qtsixa/files/ >/dev/null 2>/dev/null
if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
grep 'title="QtSixA' < index.html | md5sum > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
@@ -11,7 +12,8 @@ if [ $? = 0 ]; then
echo 'qtsixa'
fi
rm index.html
-else
+elif [ ! -f unfetchable ]
+ touch unfetchable
echo 'qtsixa (unfetchable)'
fi
diff --git a/rssyl/watch b/rssyl/watch
index 4002878..8aeed7f 100755
--- a/rssyl/watch
+++ b/rssyl/watch
@@ -2,6 +2,7 @@
wget 'http://www.claws-mail.org/plugins.php?branch=EXT' >/dev/null 2>/dev/null
if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
head --lines=$(( $(grep -n RSSyl < 'plugins.php?branch=EXT' | cut -f 1 -d \:) + 30 )) < 'plugins.php?branch=EXT' | tail --lines=30 | grep nowrap | md5sum > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
@@ -11,7 +12,8 @@ if [ $? = 0 ]; then
echo 'rssyl'
fi
rm 'plugins.php?branch=EXT'
-else
+elif [ ! -f unfetchable ]
+ touch unfetchable
echo 'rssyl (unfetchable)'
fi
diff --git a/xz-java/watch b/xz-java/watch
index 3f89728..e8bfc5f 100755
--- a/xz-java/watch
+++ b/xz-java/watch
@@ -2,6 +2,7 @@
wget 'http://git.tukaani.org/?p=xz-java.git;a=blob_plain;f=NEWS;hb=HEAD' >/dev/null 2>/dev/null
if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
md5sum < 'index.html?p=xz-java.git;a=blob_plain;f=NEWS;hb=HEAD' > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
@@ -11,7 +12,8 @@ if [ $? = 0 ]; then
echo 'xz-java'
fi
rm 'index.html?p=xz-java.git;a=blob_plain;f=NEWS;hb=HEAD'
-else
+elif [ ! -f unfetchable ]
+ touch unfetchable
echo 'xz-java (unfetchable)'
fi