aboutsummaryrefslogtreecommitdiffstats
path: root/src/redshift-gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/redshift-gtk/Makefile.am')
-rw-r--r--src/redshift-gtk/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/redshift-gtk/Makefile.am b/src/redshift-gtk/Makefile.am
index 9eb0cdb..96d7718 100644
--- a/src/redshift-gtk/Makefile.am
+++ b/src/redshift-gtk/Makefile.am
@@ -11,11 +11,14 @@ redshift_gtkdir = $(pythondir)/redshift_gtk
dist_bin_SCRIPTS = redshift-gtk
endif
-EXTRA_DIST = defs.py.in
-CLEANFILES = defs.py
+EXTRA_DIST = defs.py.in redshift-gtk.in
+CLEANFILES = defs.py redshift-gtk
# Local python definitions
defs.py: defs.py.in
$(AM_V_GEN)sed -e "s|\@bindir\@|$(bindir)|g" \
-e "s|\@localedir\@|$(localedir)|g" $< > $@
+
+redshift-gtk: redshift-gtk.in
+ $(AM_V_GEN)sed -e "s|\@pythondir\@|$(pythondir)|g" $< > $@