aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 37a0308..eca9217 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -66,3 +66,11 @@ redshift_LDADD += \
$(GEOCLUE_LIBS) $(GEOCLUE_CFLAGS)
$(GLIB_LIBS) $(GLIB_CFLAGS)
endif
+
+if ENABLE_GEOCLUE2
+redshift_SOURCES += location-geoclue2.c location-geoclue2.h
+AM_CFLAGS += \
+ $(GEOCLUE2_CFLAGS)
+redshift_LDADD += \
+ $(GEOCLUE2_LIBS) $(GEOCLUE2_CFLAGS)
+endif