aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2014-12-14 16:19:25 -0500
committerJon Lund Steffensen <jonlst@gmail.com>2014-12-15 01:47:49 -0500
commitee7e91dd8692f51acfde6a534766ff391000ed82 (patch)
treecacf18fd8b6f2c1ac9a4d1951bd85de114fa5957 /src/Makefile.am
parentsystemtime: Use gettimeofday if POSIX timers not available (diff)
downloadredshift-ng-ee7e91dd8692f51acfde6a534766ff391000ed82.tar.gz
redshift-ng-ee7e91dd8692f51acfde6a534766ff391000ed82.tar.bz2
redshift-ng-ee7e91dd8692f51acfde6a534766ff391000ed82.tar.xz
Fix #80: Add Geoclue2 location provider
This simply runs a GLib main loop when the location is requested and tries to get the location from GeoClue2. We need to run a main loop since the location is not immediately available, instead it becomes available through a signal.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 37a0308..eca9217 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -66,3 +66,11 @@ redshift_LDADD += \
$(GEOCLUE_LIBS) $(GEOCLUE_CFLAGS)
$(GLIB_LIBS) $(GLIB_CFLAGS)
endif
+
+if ENABLE_GEOCLUE2
+redshift_SOURCES += location-geoclue2.c location-geoclue2.h
+AM_CFLAGS += \
+ $(GEOCLUE2_CFLAGS)
+redshift_LDADD += \
+ $(GEOCLUE2_LIBS) $(GEOCLUE2_CFLAGS)
+endif