aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 000076f..f3109ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,8 @@
SUBDIRS = src po
ACLOCAL_AMFLAGS = -I m4
+UPDATE_ICON_CACHE = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor || :
+
EXTRA_ROOTDOC_FILES = \
HACKING \
DESIGN \
@@ -45,6 +47,14 @@ desktopdir = @datadir@/applications
desktop_DATA = $(_DESKTOP_FILES)
endif
+if ENABLE_GUI
+install-data-hook:
+ $(UPDATE_ICON_CACHE);
+
+uninstall-hook:
+ $(UPDATE_ICON_CACHE);
+endif
+
# man page
dist_man1_MANS = redshift.1