aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2014-01-06 11:39:33 -0800
committerJon Lund Steffensen <jonlst@gmail.com>2014-01-06 11:39:33 -0800
commit2c5b79fe24c52eba210f6bfce79ccf565839bef1 (patch)
tree91c2ff70da10a699dacb0cf0f2a831fa298c4ea4 /Makefile.am
parentMerge pull request #19 from TingPing/patch-1 (diff)
parentFix PyGI deprecated warnings (diff)
downloadredshift-ng-2c5b79fe24c52eba210f6bfce79ccf565839bef1.tar.gz
redshift-ng-2c5b79fe24c52eba210f6bfce79ccf565839bef1.tar.bz2
redshift-ng-2c5b79fe24c52eba210f6bfce79ccf565839bef1.tar.xz
Merge pull request #21 from TingPing/py3k
Add Python 3 support Update icon cache on install Add more files to .gitignore Fix PyGI deprecation warning
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 000076f..f3109ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,8 @@
SUBDIRS = src po
ACLOCAL_AMFLAGS = -I m4
+UPDATE_ICON_CACHE = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor || :
+
EXTRA_ROOTDOC_FILES = \
HACKING \
DESIGN \
@@ -45,6 +47,14 @@ desktopdir = @datadir@/applications
desktop_DATA = $(_DESKTOP_FILES)
endif
+if ENABLE_GUI
+install-data-hook:
+ $(UPDATE_ICON_CACHE);
+
+uninstall-hook:
+ $(UPDATE_ICON_CACHE);
+endif
+
# man page
dist_man1_MANS = redshift.1