aboutsummaryrefslogtreecommitdiffstats
path: root/src/gtk-redshift/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2010-07-28 00:48:49 +0200
committerJon Lund Steffensen <jonlst@gmail.com>2010-07-28 00:48:49 +0200
commitfb7f1b5a4a4ac73737801e1ae00306d2b5d55876 (patch)
treee8a99c21c860d61846ce0a2ebbad08a27be29579 /src/gtk-redshift/Makefile.am
parentProvide feedback on what location provider/color adjustment method that (diff)
parentOptimize indicators code. (diff)
downloadredshift-ng-fb7f1b5a4a4ac73737801e1ae00306d2b5d55876.tar.gz
redshift-ng-fb7f1b5a4a4ac73737801e1ae00306d2b5d55876.tar.bz2
redshift-ng-fb7f1b5a4a4ac73737801e1ae00306d2b5d55876.tar.xz
Merge GUI optimization from Francesco Marella with a few tweaks.
Diffstat (limited to 'src/gtk-redshift/Makefile.am')
-rw-r--r--src/gtk-redshift/Makefile.am29
1 files changed, 4 insertions, 25 deletions
diff --git a/src/gtk-redshift/Makefile.am b/src/gtk-redshift/Makefile.am
index 5896f1b..bb69459 100644
--- a/src/gtk-redshift/Makefile.am
+++ b/src/gtk-redshift/Makefile.am
@@ -1,6 +1,5 @@
-if ENABLE_STATUSICON
-gui_module=statusicon
+if ENABLE_GUI
gtk_redshift_PYTHON = \
__init__.py \
utils.py \
@@ -9,32 +8,12 @@ nodist_gtk_redshift_PYTHON = \
defs.py
gtk_redshiftdir = $(pythondir)/gtk_redshift
-bin_SCRIPTS = gtk-redshift
+dist_bin_SCRIPTS = gtk-redshift
endif
-if ENABLE_APPINDICATOR
-gui_module=rsappindicator
-gtk_redshift_PYTHON = \
- __init__.py \
- utils.py \
- rsappindicator.py
-nodist_gtk_redshift_PYTHON = \
- defs.py
-gtk_redshiftdir = $(pythondir)/gtk_redshift
-
-bin_SCRIPTS = gtk-redshift
-endif
-
-EXTRA_DIST = gtk-redshift.in \
- defs.py.in
-
-CLEANFILES = defs.py \
- gtk-redshift
-
+EXTRA_DIST = defs.py.in
+CLEANFILES = defs.py
-# Main GUI script
-gtk-redshift: gtk-redshift.in
- sed -e "s|\@gui_module\@|$(gui_module)|g" $< > $@
# Local python definitions
defs.py: defs.py.in