aboutsummaryrefslogtreecommitdiffstats
path: root/src/gtk-redshift/Makefile.am
diff options
context:
space:
mode:
authorFrancesco Marella <francesco.marella@gmail.com>2010-07-21 16:30:08 +0200
committerFrancesco Marella <francesco.marella@gmail.com>2010-07-21 16:30:08 +0200
commit34a288486d1615a7afea5dc651d316b23def7ddb (patch)
treed361d474ed99e77387a9894b603fb2273d0ee671 /src/gtk-redshift/Makefile.am
parentProvide feedback on what location provider/color adjustment method that (diff)
downloadredshift-ng-34a288486d1615a7afea5dc651d316b23def7ddb.tar.gz
redshift-ng-34a288486d1615a7afea5dc651d316b23def7ddb.tar.bz2
redshift-ng-34a288486d1615a7afea5dc651d316b23def7ddb.tar.xz
Optimize indicators code.
User, at configure time, chooses to enable or disable the gui. Determine at runtime whether to use the appindicator or status icon as fallback.
Diffstat (limited to 'src/gtk-redshift/Makefile.am')
-rw-r--r--src/gtk-redshift/Makefile.am29
1 files changed, 4 insertions, 25 deletions
diff --git a/src/gtk-redshift/Makefile.am b/src/gtk-redshift/Makefile.am
index 5896f1b..5101cef 100644
--- a/src/gtk-redshift/Makefile.am
+++ b/src/gtk-redshift/Makefile.am
@@ -1,6 +1,5 @@
-if ENABLE_STATUSICON
-gui_module=statusicon
+if ENABLE_GUI
gtk_redshift_PYTHON = \
__init__.py \
utils.py \
@@ -9,32 +8,12 @@ nodist_gtk_redshift_PYTHON = \
defs.py
gtk_redshiftdir = $(pythondir)/gtk_redshift
-bin_SCRIPTS = gtk-redshift
+dist_bin_SCRIPTS = gtk-redshift
endif
-if ENABLE_APPINDICATOR
-gui_module=rsappindicator
-gtk_redshift_PYTHON = \
- __init__.py \
- utils.py \
- rsappindicator.py
-nodist_gtk_redshift_PYTHON = \
- defs.py
-gtk_redshiftdir = $(pythondir)/gtk_redshift
-
-bin_SCRIPTS = gtk-redshift
-endif
-
-EXTRA_DIST = gtk-redshift.in \
- defs.py.in
-
-CLEANFILES = defs.py \
- gtk-redshift
-
+EXTRA_DIST = defs.py.in
-# Main GUI script
-gtk-redshift: gtk-redshift.in
- sed -e "s|\@gui_module\@|$(gui_module)|g" $< > $@
+CLEANFILES = defs.py
# Local python definitions
defs.py: defs.py.in