aboutsummaryrefslogtreecommitdiffstats
path: root/src/gtk-redshift/Makefile.am
diff options
context:
space:
mode:
authorFrancesco Marella <francesco.marella@gmail.com>2010-06-06 21:00:03 +0200
committerFrancesco Marella <francesco.marella@gmail.com>2010-06-06 21:00:03 +0200
commit07ec131ba713ebf5e49a9c57a3d2cda9cd9489ad (patch)
tree87665c8fe56119b4c86b93c833e2a95050e2a6ab /src/gtk-redshift/Makefile.am
parentMerge application indicator support from Franesco Marella. (diff)
downloadredshift-ng-07ec131ba713ebf5e49a9c57a3d2cda9cd9489ad.tar.gz
redshift-ng-07ec131ba713ebf5e49a9c57a3d2cda9cd9489ad.tar.bz2
redshift-ng-07ec131ba713ebf5e49a9c57a3d2cda9cd9489ad.tar.xz
Add a feature to toggle autostart at login
A launcher is placed in Applications -> Utility. The user toggles autostart through the user interface. The 'xdg' module is required.
Diffstat (limited to 'src/gtk-redshift/Makefile.am')
-rw-r--r--src/gtk-redshift/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/gtk-redshift/Makefile.am b/src/gtk-redshift/Makefile.am
index ddeafd6..28d5719 100644
--- a/src/gtk-redshift/Makefile.am
+++ b/src/gtk-redshift/Makefile.am
@@ -3,6 +3,7 @@ if ENABLE_STATUSICON
gui_module=statusicon
gtk_redshift_PYTHON = \
__init__.py \
+ utils.py \
statusicon.py
nodist_gtk_redshift_PYTHON = \
defs.py
@@ -15,6 +16,7 @@ if ENABLE_APPINDICATOR
gui_module=rsappindicator
gtk_redshift_PYTHON = \
__init__.py \
+ utils.py \
rsappindicator.py
nodist_gtk_redshift_PYTHON = \
defs.py
@@ -23,6 +25,12 @@ gtk_redshiftdir = $(pythondir)/gtk_redshift
bin_SCRIPTS = gtk-redshift
endif
+if ENABLE_APPINDICATOR || ENABLE_STATUSICON
+# Desktop file
+desktopdir = ${datadir}/applications
+desktop_DATA = gtk-redshift.desktop
+endif
+
EXTRA_DIST = gtk-redshift.in \
defs.py.in