aboutsummaryrefslogtreecommitdiffstats
path: root/src/gtk-redshift/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2010-06-06 23:34:49 +0200
committerJon Lund Steffensen <jonlst@gmail.com>2010-06-06 23:34:49 +0200
commit79d6d29889102a7935268dadf0b5fd2965151141 (patch)
tree2c0c2b64b38b3fc715167f283ca57fa38285e667 /src/gtk-redshift/Makefile.am
parentUpdate po files. (diff)
parentrvert commit 103: Wrap in try...except only gtk.main. (diff)
downloadredshift-ng-79d6d29889102a7935268dadf0b5fd2965151141.tar.gz
redshift-ng-79d6d29889102a7935268dadf0b5fd2965151141.tar.bz2
redshift-ng-79d6d29889102a7935268dadf0b5fd2965151141.tar.xz
Merge application indicator support from Franesco Marella.
Change GUI configuration parameter in configure.ac to --enable-gui. Distribute defs.py.in and gtk-redshift.in even if GUI is disabled. Update POTFILES.in and update translation files.
Diffstat (limited to 'src/gtk-redshift/Makefile.am')
-rw-r--r--src/gtk-redshift/Makefile.am29
1 files changed, 25 insertions, 4 deletions
diff --git a/src/gtk-redshift/Makefile.am b/src/gtk-redshift/Makefile.am
index d0d8695..ddeafd6 100644
--- a/src/gtk-redshift/Makefile.am
+++ b/src/gtk-redshift/Makefile.am
@@ -1,5 +1,6 @@
-if ENABLE_GTK
+if ENABLE_STATUSICON
+gui_module=statusicon
gtk_redshift_PYTHON = \
__init__.py \
statusicon.py
@@ -7,11 +8,31 @@ nodist_gtk_redshift_PYTHON = \
defs.py
gtk_redshiftdir = $(pythondir)/gtk_redshift
-dist_bin_SCRIPTS = gtk-redshift
-EXTRA_DIST = defs.py.in
+bin_SCRIPTS = gtk-redshift
endif
-CLEANFILES = defs.py
+if ENABLE_APPINDICATOR
+gui_module=rsappindicator
+gtk_redshift_PYTHON = \
+ __init__.py \
+ rsappindicator.py
+nodist_gtk_redshift_PYTHON = \
+ defs.py
+gtk_redshiftdir = $(pythondir)/gtk_redshift
+
+bin_SCRIPTS = gtk-redshift
+endif
+
+EXTRA_DIST = gtk-redshift.in \
+ defs.py.in
+
+CLEANFILES = defs.py \
+ gtk-redshift
+
+
+# Main GUI script
+gtk-redshift: gtk-redshift.in
+ sed -e "s|\@gui_module\@|$(gui_module)|g" $< > $@
# Local python definitions
defs.py: defs.py.in