aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2009-12-28 15:25:27 +0100
committerJon Lund Steffensen <jonlst@gmail.com>2009-12-28 15:25:27 +0100
commit27e306c66e433cf82a7539f2baa631d4aea20fa0 (patch)
tree7ee1c55c0e6a6f0c137e9ffa446446e939eb7731 /configure.ac
parentUse clock_gettime() to read current time. (diff)
downloadredshift-ng-27e306c66e433cf82a7539f2baa631d4aea20fa0.tar.gz
redshift-ng-27e306c66e433cf82a7539f2baa631d4aea20fa0.tar.bz2
redshift-ng-27e306c66e433cf82a7539f2baa631d4aea20fa0.tar.xz
Add autoconf check for clock_gettime() and floor().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1ce7ffd..09ee959 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,7 +68,9 @@ AC_TYPE_UINT16_T
# Checks for library functions.
AC_FUNC_MALLOC
-AC_CHECK_FUNCS([pow setlocale strchr])
+AC_SEARCH_LIBS([clock_gettime], [rt])
+AC_SEARCH_LIBS([floor], [m])
+AC_CHECK_FUNCS([setlocale strchr floor pow clock_gettime])
AC_CONFIG_FILES([
Makefile