aboutsummaryrefslogtreecommitdiffstats
path: root/xtux
diff options
context:
space:
mode:
Diffstat (limited to 'xtux')
-rw-r--r--xtux/.gitignore1
-rw-r--r--xtux/PKGBUILD43
l---------xtux/upload1
-rwxr-xr-xxtux/watch20
-rw-r--r--xtux/xtux.desktop8
-rw-r--r--xtux/xtux.patch37
6 files changed, 0 insertions, 110 deletions
diff --git a/xtux/.gitignore b/xtux/.gitignore
deleted file mode 100644
index 027271b..0000000
--- a/xtux/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-files
diff --git a/xtux/PKGBUILD b/xtux/PKGBUILD
deleted file mode 100644
index ad04e53..0000000
--- a/xtux/PKGBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
-# Previous maintainer: Anton Bazhenov <anton.bazhenov at gmail>
-
-pkgname=xtux
-pkgver=20030306
-pkgrel=1
-pkgdesc="A Gauntlet-style arcade game for X11 with multiplayer mode"
-arch=('i686' 'x86_64')
-url="http://xtux.sourceforge.net/"
-license=('GPL')
-depends=('libxpm')
-source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-src-${pkgver}.tar.gz"
- "${pkgname}.patch"
- "${pkgname}.desktop")
-md5sums=('6ca5d3b48c30411d1a64b4316d5cf6a9'
- 'd04e19ea067837eda0f1ce066d9c8f3a'
- '504541ae6fadcb6d56387aedda475979')
-
-build() {
- cd "${srcdir}/${pkgname}"
- patch -Np1 -i "../${pkgname}.patch"
- make
-}
-
-package() {
- cd "${srcdir}/${pkgname}"
-
- # Install binaries
- mkdir -p "${pkgdir}/usr/bin"
- install -m755 "${pkgname}" tux_serv "${pkgdir}/usr/bin"
-
- # Install data files
- mkdir -p "${pkgdir}/usr/share/${pkgname}"
- cp -r data/* "${pkgdir}/usr/share/${pkgname}"
-
- # Install pixmap and .desktop file
- install -Dm644 data/images/icon.xpm "${pkgdir}/usr/share/pixmaps/${pkgname}.xpm"
- install -Dm644 "../${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
-
- # Install documentation
- mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
- install -m644 AUTHORS CHANGELOG README* "${pkgdir}/usr/share/doc/${pkgname}"
-}
diff --git a/xtux/upload b/xtux/upload
deleted file mode 120000
index 1e7a8be..0000000
--- a/xtux/upload
+++ /dev/null
@@ -1 +0,0 @@
-../upload \ No newline at end of file
diff --git a/xtux/watch b/xtux/watch
deleted file mode 100755
index ef4c624..0000000
--- a/xtux/watch
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-[ -f 'files' ] && rm 'files'
-wget http://sourceforge.net/projects/xtux/files -O files >/dev/null 2>/dev/null
-if [ $? = 0 ]; then
- [ -f unfetchable ] && rm unfetchable
- grep 'Download xtux-src-' < files | md5sum > new-sum
- touch sum
- if [ "$(cat sum)" = "$(cat new-sum)" ]; then
- rm new-sum
- else
- mv new-sum sum
- echo 'xtux'
- fi
- rm files
-elif [ ! -f unfetchable ]; then
- touch unfetchable
- echo 'xtux (unfetchable)'
-fi
-
diff --git a/xtux/xtux.desktop b/xtux/xtux.desktop
deleted file mode 100644
index 4c5d17b..0000000
--- a/xtux/xtux.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Type=Application
-Name=XTux
-Comment=A Gauntlet-style arcade game for X11 with multiplayer mode
-Exec=xtux
-Icon=xtux.xpm
-Terminal=false
-Categories=Game;ActionGame;
diff --git a/xtux/xtux.patch b/xtux/xtux.patch
deleted file mode 100644
index 2ace5e9..0000000
--- a/xtux/xtux.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- xtux.orig/Makefile 2003-02-04 20:59:01.000000000 +0500
-+++ xtux/Makefile 2012-02-26 16:31:00.092498256 +0600
-@@ -5,7 +5,7 @@
- #============================================================#
-
- #Change this to where you want to put the data directory.
--DATADIR = `pwd`/data
-+DATADIR = /usr/share/xtux
- #Eg you might want to put the data files here......
- #DATADIR = /usr/share/games/xtux
-
---- xtux.orig/src/client/win.h 2003-03-05 20:20:04.000000000 +0500
-+++ xtux/src/client/win.h 2012-02-26 15:59:09.479154124 +0600
-@@ -11,9 +11,9 @@
- #define DEF_WIN_H 384
-
- /* Font names */
--#define MED_FONT_18 "-adobe-helvetica-medium-r-*-*-18-*-*-*-*-*-*-*"
--#define BOLD_FONT_14 "-*-helvetica-bold-r-*-*-14-*-*-*-*-*-iso8859-*"
--#define BOLD_FONT_24 "-*-helvetica-bold-r-*-*-24-*-*-*-*-*-iso8859-*"
-+#define MED_FONT_18 "-*-*-medium-r-*-*-18-*-*-*-*-*-*-*"
-+#define BOLD_FONT_14 "-*-*-bold-r-*-*-14-*-*-*-*-*-iso8859-*"
-+#define BOLD_FONT_24 "-*-*-bold-r-*-*-24-*-*-*-*-*-iso8859-*"
-
- typedef struct {
- Display *d;
---- xtux.orig/src/client/menu.c 2003-03-05 19:54:17.000000000 +0500
-+++ xtux/src/client/menu.c 2012-02-26 19:52:47.701065955 +0600
-@@ -726,7 +726,7 @@
- for( i=0 ; i<3 ; i++ )
- close(i); /* Close STD-IN, -OUT, -ERR */
-
-- system("./tux_serv -e");
-+ system("tux_serv -e");
- /* execlp( "./tux_serv", "-e" );
- perror("execlp"); */
- exit(-1);