aboutsummaryrefslogtreecommitdiffstats
path: root/xpybar/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'xpybar/PKGBUILD')
-rw-r--r--xpybar/PKGBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/xpybar/PKGBUILD b/xpybar/PKGBUILD
index 64b43e6..35d4f5d 100644
--- a/xpybar/PKGBUILD
+++ b/xpybar/PKGBUILD
@@ -1,35 +1,34 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=xpybar
-pkgver=1.18
+pkgver=1.18.1
pkgrel=1
pkgdesc="A highly extensible minimalistic dock panel configured in Python 3"
arch=(any)
url="https://github.com/maandree/xpybar"
license=('GPL3' 'AGPL3')
-depends=(python3 argparser-python python-xlib xorg-xrandr)
-optdepends=("linux: most of the monitors require Linux's procfs or sysfs"
+depends=(python3 argparser-python 'python-xlib>=0.18' xorg-xrandr)
+optdepends=("alarm: for limiting the time of a file search in locks"
"curl: for Internet services"
- "python-pyalsaaudio: for ALSA volume control"
- "hdparm: hdparm: for hdparm support"
- "python-pytz: for timezone support"
- "python-sysv-ipc: for ropty example"
- "iputils: for ping support"
- "inotify-tools: for inotify support"
- "alarm: for limiting the time of a file search in locks"
+ "file: for image support"
"findutils: for file search in locks"
"graphicsmagick: for image support"
+ "hdparm: hdparm: for hdparm support"
+ "ii: for ii support"
"imagemagick: for image support"
- "file: for image support"
- "librsvg: for image support"
- "solar-python>=2.5: for solar data"
"inotify-tools: for ii and inotify support"
- "ii: for ii support"
- "pdeath: for automatic killing of child processes on exit")
+ "iputils: for ping support"
+ "librsvg: for image support"
+ "linux: most of the monitors require Linux's procfs or sysfs"
+ "pdeath: for automatic killing of child processes on exit"
+ "python-pyalsaaudio: for ALSA volume control"
+ "python-pytz: for timezone support"
+ "python-sysv-ipc: for ropty example"
+ "solar-python>=2.5: for solar data")
makedepends=(make coreutils sed zip auto-auto-complete texinfo)
install=xpybar.install
source=($url/archive/$pkgver.tar.gz)
-sha256sums=(78d23cd1af2f32d13d6dd0ddce0767a58fa80d53c4d897562c7a2c2f8196656f)
+sha256sums=(e4fed5d35b6ba98eb05163bd897475262457080a3a36e36f0327932eb18dc97c)
build() {