aboutsummaryrefslogtreecommitdiffstats
path: root/spot-on/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'spot-on/PKGBUILD')
-rw-r--r--spot-on/PKGBUILD30
1 files changed, 0 insertions, 30 deletions
diff --git a/spot-on/PKGBUILD b/spot-on/PKGBUILD
deleted file mode 100644
index db5bb18..0000000
--- a/spot-on/PKGBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Maintainer: Mattias Andrée <m@`base64 -d`(bWFhbmRyZWU).se>
-
-pkgname=spot-on
-pkgver=2017.01.20
-pkgrel=1
-pkgdesc='An exploratory research project investigating a variety of communications protocols'
-url='http://spot-on.sourceforge.net/'
-arch=('i686' 'x86_64')
-license=('custom:3-clause BSD')
-depends=('qt5-base' 'geoip>=1.5.1' 'libgcrypt>=1.5' 'openssl>=0.9.8' 'lksctp-tools' 'qt5-multimedia' "libspoton=${pkgver}" 'libntru' 'qt5-declarative')
-makedepends=('qt5-base' 'geoip>=1.5.1' 'libgcrypt>=1.5' 'openssl>=0.9.8' 'lksctp-tools' 'qt5-multimedia' 'qt5-tools' 'make' 'gcc' 'qt5-declarative')
-source=("Spot-On-${pkgver}.zip::http://downloads.sourceforge.net/project/spot-on/Version%20${pkgver}/Spot-On-Src.d.zip?r=")
-sha256sums=('45ff31d37092f653c0b94b4dc47b16f64c4b1327841bacfd8a4f624b63a6e04c')
-
-
-build() {
- cd "$srcdir/spot-on.d/branches/trunk"
- qmake-qt5 -o Makefile spot-on.qt5.pro
- make
-}
-
-package () {
- cd "$srcdir/spot-on.d/branches/trunk"
- install -dm755 -- "$pkgdir/usr/lib/spot-on"
- install -m755 -- Spot-On "$pkgdir/usr/lib/spot-on/Spot-On"
- install -m755 -- Spot-On-Kernel "$pkgdir/usr/lib/spot-on/Spot-On-Kernel"
- install -dm755 -- "$pkgdir/usr/bin"
- ln -s ../lib/spot-on/Spot-On -- "$pkgdir/usr/bin/spot-on"
-}
-