aboutsummaryrefslogtreecommitdiffstats
path: root/sleeping-getty/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'sleeping-getty/PKGBUILD')
-rw-r--r--sleeping-getty/PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/sleeping-getty/PKGBUILD b/sleeping-getty/PKGBUILD
index 7a7007a..9adef5c 100644
--- a/sleeping-getty/PKGBUILD
+++ b/sleeping-getty/PKGBUILD
@@ -1,28 +1,24 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=sleeping-getty
-pkgver=1.0.1
+pkgver=1.1
pkgrel=1
pkgdesc="Do not start a fullblown getty before it is necessary"
arch=(i686 x86_64)
url="https://github.com/maandree/sleeping-getty"
-license=('GPL3' 'custom:GFDL1.3')
-depends=(linux glibc)
-makedepends=(linux-api-headers glibc make coreutils gcc 'texinfo>=4.11')
-install=$pkgname.install
-source=($url/archive/$pkgver.tar.gz)
-sha256sums=(f0844dc0f232fd83da1b18063e0850209996b66338120035c17c94cd8326dc31)
-
+license=('custom:ISC')
+depends=()
+makedepends=(linux-api-headers)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=(7d7303e8c7f6d543d33a1c2686f000362c42764821bf4346af7004124edb4136)
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --sbindir=/usr/bin OPTIMISE=-Os
- make
+ make PREFIX=/usr
}
-
package() {
cd "$srcdir/$pkgname-$pkgver"
- make install N=: DESTDIR="$pkgdir"
+ make PREFIX=/usr install DESTDIR="$pkgdir"
+ mv -- "$pkgdir/usr/sbin" "$pkgdir/usr/bin"
}
-