aboutsummaryrefslogtreecommitdiffstats
path: root/rc.local.d/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'rc.local.d/PKGBUILD')
-rw-r--r--rc.local.d/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/rc.local.d/PKGBUILD b/rc.local.d/PKGBUILD
new file mode 100644
index 0000000..b69cc69
--- /dev/null
+++ b/rc.local.d/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWF0dGlhcy5hbmRyZWU)@protonmail.com>
+
+pkgname=rc.local.d
+pkgver=1396841433
+pkgrel=1
+pkgdesc="Startup-system independent startup scripts"
+url="https://github.com/GNU-Pony/rc.local.d"
+arch=(any)
+license=(GPL3)
+depends=(bash)
+optdepends=(linux findutils kbd ntp alsa-utils)
+makedepends=(make coreutils general-preprocessor)
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(a74d39dd6e6825509112f9796e87b138ad1a810e6dd578bbacec1c47891e171e)
+
+
+build() {
+ cd "${srcdir}/rc.local.d-${pkgver}"
+ make PKGNAME="${pkgname}"
+}
+
+package() {
+ cd "${srcdir}/rc.local.d-${pkgver}"
+ make PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+