aboutsummaryrefslogtreecommitdiffstats
path: root/qtchess/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'qtchess/PKGBUILD')
-rw-r--r--qtchess/PKGBUILD33
1 files changed, 0 insertions, 33 deletions
diff --git a/qtchess/PKGBUILD b/qtchess/PKGBUILD
deleted file mode 100644
index fb5fdd3..0000000
--- a/qtchess/PKGBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Maintainer: Mattias Andrée <m@`base64 -d`(bWFhbmRyZWU).se>
-# Contributor: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
-
-pkgname=qtchess
-pkgver=2021.03.15
-pkgrel=2
-pkgdesc='Online chess game client written in Qt'
-url='https://textbrowser.github.io/qtchess/'
-arch=('i686' 'x86_64')
-license=('custom:3-clause BSD')
-# (license notice included in qtchess_main.cc)
-depends=('qt5-base' 'libgl')
-makedepends=('qt5-base' 'libgl' 'qt5-tools')
-source=(qtchess-${pkgver}.tar.gz::"https://github.com/textbrowser/qtchess/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('b67e182beca7d203dd07b995a6d4cae752dc42ed76439694e1befe5d6bd5f2be')
-
-
-prepare () {
- cd "$srcdir/qtchess-${pkgver}"
- sed '/-Werror/d' < qtchess.pro > qtchess.pro.fixed
-}
-
-build () {
- cd "$srcdir/qtchess-${pkgver}"
- qmake-qt5 -o Makefile qtchess.pro.fixed
- make
-}
-
-package () {
- cd "$srcdir/qtchess-${pkgver}"
- mkdir -p -- "${pkgdir}/usr/bin/"
- cp -- QtChess "${pkgdir}/usr/bin/qtchess"
-}