aboutsummaryrefslogtreecommitdiffstats
path: root/pytagomacs
diff options
context:
space:
mode:
Diffstat (limited to 'pytagomacs')
-rw-r--r--pytagomacs/PKGBUILD28
l---------pytagomacs/upload1
2 files changed, 29 insertions, 0 deletions
diff --git a/pytagomacs/PKGBUILD b/pytagomacs/PKGBUILD
new file mode 100644
index 0000000..29b9590
--- /dev/null
+++ b/pytagomacs/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWF0dGlhcy5hbmRyZWU)@protonmail.com>
+
+pkgname=pytagomacs
+pkgver=1443787175
+pkgrel=1
+pkgdesc="An Emacs like key–value editor library for Python"
+url="https://github.com/GNU-Pony/pytagomacs"
+arch=(any)
+license=(GPL3)
+depends=(python3 coreutils)
+makedepends=(make coreutils python3)
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(e259f77bd3a34acfbe2d8327cf9655d31a511a2521caaf9c63f3f1e35bb981ac)
+
+
+build() {
+ cd "${srcdir}/pytagomacs-${pkgver}"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "${srcdir}/pytagomacs-${pkgver}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+
diff --git a/pytagomacs/upload b/pytagomacs/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/pytagomacs/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file