aboutsummaryrefslogtreecommitdiffstats
path: root/pony
diff options
context:
space:
mode:
Diffstat (limited to 'pony')
-rw-r--r--pony/PKGBUILD25
-rwxr-xr-xpony/watch16
2 files changed, 41 insertions, 0 deletions
diff --git a/pony/PKGBUILD b/pony/PKGBUILD
new file mode 100644
index 0000000..6ebf2ed
--- /dev/null
+++ b/pony/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Arch Haskell Team <arch-haskell@haskell.org>
+_hkgname=pony
+pkgname=pony
+pkgver=1.0
+pkgrel=3
+pkgdesc="Can I have a pony?"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=('ghc')
+depends=('gmp')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O
+ runhaskell Setup build
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
+md5sums=('10ce264fbbe185a3f6290017c5ea58b2')
diff --git a/pony/watch b/pony/watch
new file mode 100755
index 0000000..c8a8af5
--- /dev/null
+++ b/pony/watch
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+wget http://hackage.haskell.org/package/pony >/dev/null 2>/dev/null
+if [ $? = 0 ]; then
+ md5sum < pony > new-sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'pony'
+ fi
+ rm pony
+else
+ echo 'pony (unfetchable)'
+fi
+