aboutsummaryrefslogtreecommitdiffstats
path: root/libsha1
diff options
context:
space:
mode:
Diffstat (limited to 'libsha1')
-rw-r--r--libsha1/PKGBUILD29
l---------libsha1/upload1
2 files changed, 30 insertions, 0 deletions
diff --git a/libsha1/PKGBUILD b/libsha1/PKGBUILD
new file mode 100644
index 0000000..2a0de0b
--- /dev/null
+++ b/libsha1/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+
+pkgname=libsha1
+pkgver=1.0
+pkgrel=1
+pkgdesc="SHA-1 and SHA-0 hashing library"
+arch=(i686 x86_64)
+url="https://github.com/maandree/libsha1"
+license=('custom:ISC')
+depends=()
+checkdepends=()
+makedepends=()
+source=(libsha1-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha256sums=(94b9de0edde7a922bb96ccc3585f06b9d9bce0adc0261bfd4e19048544782825)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
diff --git a/libsha1/upload b/libsha1/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/libsha1/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file