aboutsummaryrefslogtreecommitdiffstats
path: root/libpassphrase
diff options
context:
space:
mode:
Diffstat (limited to 'libpassphrase')
-rw-r--r--libpassphrase/PKGBUILD58
-rw-r--r--libpassphrase/libpassphrase.install20
l---------libpassphrase/upload1
3 files changed, 79 insertions, 0 deletions
diff --git a/libpassphrase/PKGBUILD b/libpassphrase/PKGBUILD
new file mode 100644
index 0000000..c41588f
--- /dev/null
+++ b/libpassphrase/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWF0dGlhcy5hbmRyZWU)@protonmail.com>
+
+pkgname=libpassphrase
+pkgver=1449331105
+pkgrel=1
+pkgdesc="Personalisable library for TTY passphrase reading"
+url="https://github.com/GNU-Pony/libpassphrase"
+arch=(i686 x86_64 armv6h)
+license=(GPL3)
+depends=(glibc)
+makedepends=(make coreutils gcc texinfo)
+optdepends=('passcheck: for strength meter')
+install=libpassphrase.install
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(76044a7af93dd6a956c6fb9a13af711a2c90b260420a2bf1b272d624deefafb7)
+
+
+build() {
+ cd "${srcdir}/libpassphrase-${pkgver}"
+
+ options=()
+ #options+=( PASSPHRASE_ECHO ) # Do not hide the passphrase
+ #options+=( PASSPHRASE_STAR ) # Use '*' for each character instead of no echo
+ options+=( PASSPHRASE_TEXT ) # Use '(empty)' and not '(not empty)' instead of no echo
+ #options+=( PASSPHRASE_REALLOC ) # Soften security by using `realloc`
+ options+=( PASSPHRASE_MOVE ) # Enable move of point
+ options+=( PASSPHRASE_INSERT ) # Enable insert mode
+ options+=( PASSPHRASE_OVERRIDE ) # Enable override mode
+ options+=( PASSPHRASE_DELETE ) # Enable reversed erase command
+ options+=( PASSPHRASE_CONTROL ) # Enable use of control key combinations
+ options+=( PASSPHRASE_DEDICATED ) # Enable use of dedicated keys
+ options+=( DEFAULT_INSERT ) # Use insert mode as default
+ options+=( PASSPHRASE_INVALID ) # Prevent duplication of non-initialised memory
+ options+=( PASSPHRASE_METER ) # Enable strength meter for new passphrases
+ ## see `info '(libpassphrase)' configuring` for details
+
+ star_char="*"
+ text_empty="(empty)"
+ text_not_empty="(not empty)"
+ text_strength="Strength:"
+
+ make PKGNAME="${pkgname}" OPTIONS="${options[*]}" \
+ PASSPHRASE_STAR_CHAR="${star_char}" \
+ PASSPHRASE_TEXT_EMPTY="${text_empty}" \
+ PASSPHRASE_TEXT_NOT_EMPTY="${text_not_empty}" \
+ PASSPHRASE_TEXT_STRENGTH="${text_strength}"
+ ## it is also possible to add PASSPHRASE_STRENGTH_LIMITS_HEADER
+}
+
+package() {
+ cd "${srcdir}/libpassphrase-${pkgver}"
+
+ make PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install
+
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+
diff --git a/libpassphrase/libpassphrase.install b/libpassphrase/libpassphrase.install
new file mode 100644
index 0000000..f69bfba
--- /dev/null
+++ b/libpassphrase/libpassphrase.install
@@ -0,0 +1,20 @@
+_file="libpassphrase"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
diff --git a/libpassphrase/upload b/libpassphrase/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/libpassphrase/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file