aboutsummaryrefslogtreecommitdiffstats
path: root/latex-fitch
diff options
context:
space:
mode:
Diffstat (limited to 'latex-fitch')
-rw-r--r--latex-fitch/PKGBUILD8
l---------latex-fitch/upload1
-rwxr-xr-xlatex-fitch/watch6
3 files changed, 8 insertions, 7 deletions
diff --git a/latex-fitch/PKGBUILD b/latex-fitch/PKGBUILD
index e839bdb..f8bd824 100644
--- a/latex-fitch/PKGBUILD
+++ b/latex-fitch/PKGBUILD
@@ -3,17 +3,17 @@
pkgname=latex-fitch
pkgver=1.6
-pkgrel=1
+pkgrel=2
pkgdesc="A LaTeX package for Fitch-style proofs"
arch=('any')
url="http://folk.uio.no/johanw/FitchSty.html"
license=('GPL')
depends=('tetex')
install=fitch.install
-source=(http://folk.uio.no/johanw/fitch.sty)
+#source=(http://folk.uio.no/johanw/fitch.sty)
+source=(fitch.sty)
md5sums=('d62bdd0267c217d6017baef950b9205a')
package() {
- mkdir -p $startdir/pkg/usr/share/texmf-dist/tex/latex/fitch
- cp $startdir/fitch.sty $startdir/pkg/usr/share/texmf-dist/tex/latex/fitch
+ install -Dm644 "${srcdir}/fitch.sty" "${pkgdir}/usr/share/texmf-dist/tex/latex/fitch"
}
diff --git a/latex-fitch/upload b/latex-fitch/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/latex-fitch/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file
diff --git a/latex-fitch/watch b/latex-fitch/watch
index 8dca4f7..9c62075 100755
--- a/latex-fitch/watch
+++ b/latex-fitch/watch
@@ -1,12 +1,12 @@
#!/bin/sh
-[ -f fitch.sty ] && rm fitch.sty
+[ -f fitch.sty.new ] && rm fitch.sty.new
-wget 'http://folk.uio.no/johanw/fitch.sty' -O fitch.sty >/dev/null 2>/dev/null
+wget 'http://folk.uio.no/johanw/fitch.sty' -O fitch.sty.new >/dev/null 2>/dev/null
if [ $? = 0 ]; then
[ -f unfetchable ] && rm unfetchable
- md5sum fitch.sty > new-sum
+ md5sum fitch.sty.new > new-sum
touch sum
if [ "$(cat sum)" = "$(cat new-sum)" ]; then
rm new-sum