aboutsummaryrefslogtreecommitdiffstats
path: root/emacs-prolog-mode (not maintaining)
diff options
context:
space:
mode:
Diffstat (limited to 'emacs-prolog-mode (not maintaining)')
-rw-r--r--emacs-prolog-mode (not maintaining)/PKGBUILD18
-rw-r--r--emacs-prolog-mode (not maintaining)/emacs-prolog-mode.install19
-rwxr-xr-xemacs-prolog-mode (not maintaining)/watch21
3 files changed, 58 insertions, 0 deletions
diff --git a/emacs-prolog-mode (not maintaining)/PKGBUILD b/emacs-prolog-mode (not maintaining)/PKGBUILD
new file mode 100644
index 0000000..563e6b0
--- /dev/null
+++ b/emacs-prolog-mode (not maintaining)/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=emacs-prolog-mode
+pkgver=1.25
+pkgrel=1
+pkgdesc="Prolog mode for Emacs"
+arch=(any)
+url=http://turing.ubishops.ca/home/bruda/emacs-prolog/
+license=(GPL)
+depends=(emacs)
+install=$pkgname.install
+source=(http://bruda.ca/_media/emacs/prolog.el)
+sha256sums=('d01bc2184a07b59d62f58635a81a75b00055a858d322c0f6ebb8b03e7213cd41')
+
+package() {
+ install -Dm644 "$srcdir"/prolog.el "$pkgdir"/usr/share/emacs/site-lisp/prolog.el
+}
+
diff --git a/emacs-prolog-mode (not maintaining)/emacs-prolog-mode.install b/emacs-prolog-mode (not maintaining)/emacs-prolog-mode.install
new file mode 100644
index 0000000..450b39e
--- /dev/null
+++ b/emacs-prolog-mode (not maintaining)/emacs-prolog-mode.install
@@ -0,0 +1,19 @@
+post_install () {
+ cat << __EOF__
+
+==> Insert into your ~/.emacs or ~/.xemacs/init.el the following lines:
+
+(autoload 'run-prolog "prolog" "Start a Prolog sub-process." t)
+(autoload 'prolog-mode "prolog" "Major mode for editing Prolog programs." t)
+(autoload 'mercury-mode "prolog" "Major mode for editing Mercury programs." t)
+(setq prolog-system 'swi)
+(setq auto-mode-alist (append '(("\\.pl$" . prolog-mode)
+ ("\\.m$" . mercury-mode))
+ auto-mode-alist))
+
+__EOF__
+}
+
+post_upgrade () {
+ post_install
+}
diff --git a/emacs-prolog-mode (not maintaining)/watch b/emacs-prolog-mode (not maintaining)/watch
new file mode 100755
index 0000000..8832b47
--- /dev/null
+++ b/emacs-prolog-mode (not maintaining)/watch
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+[ -f prolog.el ] && rm prolog.el
+
+wget 'http://bruda.ca/_media/emacs/prolog.el' -O prolog.el >/dev/null 2>/dev/null
+
+if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
+ md5sum prolog > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'emacs-prolog-mode'
+ fi
+elif [ ! -f unfetchable ]; then
+ touch unfetchable
+ echo 'emacs-prolog-mode (unfetchable)'
+fi
+