aboutsummaryrefslogtreecommitdiffstats
path: root/dash-pipe
diff options
context:
space:
mode:
Diffstat (limited to 'dash-pipe')
-rw-r--r--dash-pipe/PKGBUILD24
l---------dash-pipe/upload1
-rwxr-xr-xdash-pipe/watch21
3 files changed, 0 insertions, 46 deletions
diff --git a/dash-pipe/PKGBUILD b/dash-pipe/PKGBUILD
deleted file mode 100644
index 0f2f640..0000000
--- a/dash-pipe/PKGBUILD
+++ /dev/null
@@ -1,24 +0,0 @@
-# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
-
-pkgname=dashpipe
-pkgver=1.0.3
-pkgrel=1
-pkgdesc="A utility for ponifying and deponifying text"
-arch=('any')
-url="http://github.com/DanielOaks/$pkgname/"
-license=('MIT')
-depends=('perl')
-makedepends=('git')
-source=("https://github.com/DanielOaks/dashpipe/archive/v${pkgver}.tar.gz")
-sha256sums=('c8ed2242113bb5cd867ed934fe0f9745666c289711e70bb54a3c5903e04e3553')
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- make
-}
-
-package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
-}
-
diff --git a/dash-pipe/upload b/dash-pipe/upload
deleted file mode 120000
index 1e7a8be..0000000
--- a/dash-pipe/upload
+++ /dev/null
@@ -1 +0,0 @@
-../upload \ No newline at end of file
diff --git a/dash-pipe/watch b/dash-pipe/watch
deleted file mode 100755
index 2acc27b..0000000
--- a/dash-pipe/watch
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-[ -f release ] && rm release
-
-wget 'https://github.com/DanielOaks/dashpipe/releases' -O release >/dev/null 2>/dev/null
-
-if [ $? = 0 ]; then
- [ -f unfetchable ] && rm unfetchable
- grep -Po 'href="[^"]*\.tar\.gz"' < release | md5sum > new-sum
- touch sum
- if [ "$(cat sum)" = "$(cat new-sum)" ]; then
- rm new-sum
- else
- mv new-sum sum
- echo 'dashpipe'
- fi
-elif [ ! -f unfetchable ]; then
- touch unfetchable
- echo 'dashpipe (unfetchable)'
-fi
-