aboutsummaryrefslogtreecommitdiffstats
path: root/cmdipc
diff options
context:
space:
mode:
Diffstat (limited to 'cmdipc')
-rw-r--r--cmdipc/PKGBUILD27
-rw-r--r--cmdipc/cmdipc.install20
l---------cmdipc/upload1
3 files changed, 48 insertions, 0 deletions
diff --git a/cmdipc/PKGBUILD b/cmdipc/PKGBUILD
new file mode 100644
index 0000000..a9595f2
--- /dev/null
+++ b/cmdipc/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=cmdipc
+pkgver=1.3
+pkgrel=2
+pkgdesc="System V and POSIX IPC from the command line"
+arch=(any)
+url="https://github.com/maandree/cmdipc"
+license=('GPL3' 'custom:GFDL1.3')
+depends=(python3 python-posix_ipc python-sysv-ipc argparser-python)
+makedepends=(make sed zip texinfo)
+install=cmdipc.install
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(1f1eb0e18678140ef7b0f1f30ae11ec8aef8357aec61fd67fb0129fe5bd8d70b)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr install DESTDIR="$pkgdir"
+}
+
diff --git a/cmdipc/cmdipc.install b/cmdipc/cmdipc.install
new file mode 100644
index 0000000..1ff9749
--- /dev/null
+++ b/cmdipc/cmdipc.install
@@ -0,0 +1,20 @@
+_file="cmdipc"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
diff --git a/cmdipc/upload b/cmdipc/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/cmdipc/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file