aboutsummaryrefslogtreecommitdiffstats
path: root/blender-plugin-vectex
diff options
context:
space:
mode:
Diffstat (limited to 'blender-plugin-vectex')
-rw-r--r--blender-plugin-vectex/64bit.patch23
-rw-r--r--blender-plugin-vectex/PKGBUILD26
-rwxr-xr-xblender-plugin-vectex/watch17
3 files changed, 66 insertions, 0 deletions
diff --git a/blender-plugin-vectex/64bit.patch b/blender-plugin-vectex/64bit.patch
new file mode 100644
index 0000000..29fb433
--- /dev/null
+++ b/blender-plugin-vectex/64bit.patch
@@ -0,0 +1,23 @@
+--- Makefile 2008-02-25 02:05:56.000000000 +0000
++++ Makefile_modified 2008-05-09 21:00:18.000000000 +0100
+@@ -8,7 +8,7 @@
+ expat: expat-1.95.8/.libs/libexpat.a
+
+ expat-1.95.8/.libs/libexpat.a:
+- cd expat-1.95.8; ./configure; make
++ cd expat-1.95.8; CFLAGS="$(CFLAGS) -fPIC" ./configure; make
+
+ INC=-fPIC -shared -O -ansi -Iblender -Iagg-2.5/include -Iexpat-1.95.8/lib
+ # -DDEBUG
+--- agg-2.5/src/Makefile 2006-10-09 05:07:22.000000000 +0100
++++ agg-2.5/src/Makefile_modified 2008-05-09 21:01:16.000000000 +0100
+@@ -53,7 +53,7 @@
+ rm -rf ctrl/SunWS_cache
+
+ %.o: %.cpp
+- $(CXX) -c $(CXXFLAGS) $*.cpp -o $@
++ $(CXX) -fPIC -c $(CXXFLAGS) $*.cpp -o $@
+
+ %.o: %.c
+- $(C) -c $(CXXFLAGS) $*.c -o $@
++ $(C) -fPIC -c $(CXXFLAGS) $*.c -o $@
diff --git a/blender-plugin-vectex/PKGBUILD b/blender-plugin-vectex/PKGBUILD
new file mode 100644
index 0000000..22ebc5d
--- /dev/null
+++ b/blender-plugin-vectex/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributer: N30N <archlinux@alunamation.com>
+
+pkgname=blender-plugin-vectex
+pkgver=0.9
+pkgrel=1
+pkgdesc="Vectex is a SVG vector texture plugin for Blender"
+url="http://code.google.com/p/vectex/"
+license="GPL"
+arch=('i686' 'x86_64')
+depends=('blender')
+makedepends=()
+source=(http://vectex.googlecode.com/files/vectex-${pkgver}-fix.tar.bz2 '64bit.patch')
+md5sums=('e36937018056f072f35a8df3bb7574ad' '98ddd03b81bff9b2f923e8fd5e449b1b')
+
+build() {
+ cd $startdir/src/vectex-$pkgver
+
+ if [ ${CARCH} == "x86_64" ]; then
+ patch -p0 < $startdir/src/64bit.patch
+ fi
+
+ msg "Starting build process."
+ make || return 1
+
+ install -D -m755 vectex.so $startdir/pkg/usr/share/blender/plugins/texture/vectex.so
+}
diff --git a/blender-plugin-vectex/watch b/blender-plugin-vectex/watch
new file mode 100755
index 0000000..21bc8a0
--- /dev/null
+++ b/blender-plugin-vectex/watch
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+wget http://code.google.com/p/vectex/ >/dev/null 2>/dev/null
+if [ $? = 0 ]; then
+ grep release < index.html | md5sum > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'blender-plugin-vectex'
+ fi
+ rm index.html
+else
+ echo 'blender-plugin-vectex (unfetchable)'
+fi
+