aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dooble/PKGBUILD20
-rw-r--r--icu-48/PKGBUILD44
-rw-r--r--icu-48/icu.8198.revert.icu5431.patch129
-rw-r--r--syncterm/PKGBUILD20
-rw-r--r--xz-java-git/PKGBUILD14
-rw-r--r--xz-java/PKGBUILD11
-rw-r--r--xz-java/xz-java-1.1.tar.xzbin53148 -> 0 bytes
7 files changed, 209 insertions, 29 deletions
diff --git a/dooble/PKGBUILD b/dooble/PKGBUILD
index c528aa5..c272667 100644
--- a/dooble/PKGBUILD
+++ b/dooble/PKGBUILD
@@ -2,26 +2,26 @@
# Maintainer: Mattias Andrée
pkgname=dooble
-pkgver=1.37
+pkgver=1.38
pkgrel=1
pkgdesc='A safe WebKit Web browser'
url=http://dooble.sourceforge.net/
arch=(i686 x86_64)
license=(GPL2)
-source=("http://downloads.sourceforge.net/project/dooble/Version%201.37/Dooble_Lin64.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fdooble%2Ffiles%2FVersion%25201.37%2F&ts=1352909582&use_mirror=freefr")
-md5sums=(3ba01abc425130d9870c81919a909096)
+source=("https://downloads.sourceforge.net/project/dooble/Version%201.38/Dooble_Lin64.tar.gz?r=&ts=1358219172&use_mirror=heanet")
+md5sums=(6f38c6981022966791e14e7694c72dd6)
depends=(libpng12)
_sedfiles="dooble.sh qt.conf"
[ "${CARCH}" == 'i686' ] &&
- source[0]="http://downloads.sourceforge.net/project/dooble/Version%201.37/Dooble_Lin32.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fdooble%2Ffiles%2FVersion%25201.37%2F&ts=1352909582&use_mirror=freefr" &&
- md5sums[0]=c1aab6e21f387ee4046cf9fe357a151f
+ source[0]="https://downloads.sourceforge.net/project/dooble/Version%201.38/Dooble_Lin32.tar.gz?r=&ts=1358219172&use_mirror=heanet" &&
+ md5sums[0]=a19ca86cf5bff9a382bdbdd1e7060225
package()
{
- msg "Moving precompiled files into \$pkgfir"
+ msg "Moving precompiled files into \$pkgdir"
mv "$srcdir/usr" "$pkgdir"
@@ -38,17 +38,13 @@ package()
for file in $_sedfiles
do
- cp "$pkgdir/opt/dooble/$file" "$pkgdir/opt/dooble/$file~"
- sed -e s/'\/usr\/local\/dooble'/'\/opt\/dooble'/g < "$pkgdir/opt/dooble/$file~" > "$pkgdir/opt/dooble/$file"
- rm "$pkgdir/opt/dooble/$file~"
+ sed -i s_'/usr/local/dooble'_'/opt/dooble'_g "$pkgdir/opt/dooble/$file"
done
for file in "Dooble"
do
- cp "$pkgdir/opt/dooble/$file" "$pkgdir/opt/dooble/$file~"
## hehehe
- sed -e s/'\/usr\/local\/dooble\/Lib\x00'/'\/opt\/dooble\/Lib\x00\x00\x00\x00\x00\x00\x00'/g < "$pkgdir/opt/dooble/$file~" > "$pkgdir/opt/dooble/$file"
- rm "$pkgdir/opt/dooble/$file~"
+ sed -i s_'/usr/local/dooble/Lib\x00'_'/opt/dooble/Lib\x00\x00\x00\x00\x00\x00\x00'_g "$pkgdir/opt/dooble/$file"
done
diff --git a/icu-48/PKGBUILD b/icu-48/PKGBUILD
new file mode 100644
index 0000000..7b622e7
--- /dev/null
+++ b/icu-48/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Mattias Andrée
+# Original Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Original Contributor: Art Gramlich <art@gramlich-net.com>
+
+pkgname=icu-48
+_pkgname=icu
+pkgver=4.8.1.1
+pkgrel=1
+pkgdesc="International Components for Unicode library"
+arch=(i686 x86_64)
+url="http://www.icu-project.org/"
+license=('custom:"icu"')
+depends=('gcc-libs' 'sh')
+source=(#http://download.icu-project.org/files/${_pkgname}4c/${pkgver}/${_pkgname}4c-${pkgver/./_}-src.tgz
+ http://download.icu-project.org/files/${_pkgname}4c/${pkgver}/${_pkgname}4c-${pkgver//./_}-src.tgz
+ icu.8198.revert.icu5431.patch)
+md5sums=('ea93970a0275be6b42f56953cd332c17'
+ 'ebd5470fc969c75e52baf4af94a9ee82')
+
+build() {
+ cd "${srcdir}/icu/source"
+ # fix Malayalam encoding https://bugzilla.redhat.com/show_bug.cgi?id=654200
+ patch -Rp3 -i "${srcdir}/icu.8198.revert.icu5431.patch"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd ${srcdir}/icu/source
+ make -j1 DESTDIR="${pkgdir}" install
+
+ rm -r "${pkgdir}/usr/include/"
+ rm -r "${pkgdir}/usr/share/man/"
+ rm -r "${pkgdir}/usr/sbin/"
+ rm -r "${pkgdir}/usr/bin/"
+ rm -r "${pkgdir}/usr/lib/pkgconfig"
+ rm "${pkgdir}/usr/lib/icu/pkgdata.inc"
+ rm "${pkgdir}/usr/lib/icu/Makefile.inc"
+ rm "${pkgdir}/usr/lib/icu/current"
+ rm "${pkgdir}/usr/lib/"*.so
+}
+
diff --git a/icu-48/icu.8198.revert.icu5431.patch b/icu-48/icu.8198.revert.icu5431.patch
new file mode 100644
index 0000000..4c3e78b
--- /dev/null
+++ b/icu-48/icu.8198.revert.icu5431.patch
@@ -0,0 +1,129 @@
+Index: icu/trunk/source/layout/IndicReordering.cpp
+===================================================================
+--- icu/trunk/source/layout/IndicReordering.cpp (revision 25772)
++++ icu/trunk/source/layout/IndicReordering.cpp (revision 26090)
+@@ -126,4 +126,8 @@
+ FeatureMask fSMFeatures;
+
++ LEUnicode fPreBaseConsonant;
++ LEUnicode fPreBaseVirama;
++ le_int32 fPBCIndex;
++ FeatureMask fPBCFeatures;
+
+ void saveMatra(LEUnicode matra, le_int32 matraIndex, IndicClassTable::CharClass matraClass)
+@@ -172,5 +176,6 @@
+ fMatraFeatures(0), fMPreOutIndex(-1), fMPreFixups(mpreFixups),
+ fVMabove(0), fVMpost(0), fVMIndex(0), fVMFeatures(0),
+- fSMabove(0), fSMbelow(0), fSMIndex(0), fSMFeatures(0)
++ fSMabove(0), fSMbelow(0), fSMIndex(0), fSMFeatures(0),
++ fPreBaseConsonant(0), fPreBaseVirama(0), fPBCIndex(0), fPBCFeatures(0)
+ {
+ // nothing else to do...
+@@ -191,4 +196,6 @@
+ fVMabove = fVMpost = 0;
+ fSMabove = fSMbelow = 0;
++
++ fPreBaseConsonant = fPreBaseVirama = 0;
+ }
+
+@@ -386,4 +393,12 @@
+ }
+
++ void notePreBaseConsonant(le_uint32 index,LEUnicode PBConsonant, LEUnicode PBVirama, FeatureMask features)
++ {
++ fPBCIndex = index;
++ fPreBaseConsonant = PBConsonant;
++ fPreBaseVirama = PBVirama;
++ fPBCFeatures = features;
++ }
++
+ void noteBaseConsonant()
+ {
+@@ -465,4 +480,20 @@
+ }
+
++ void writePreBaseConsonant()
++ {
++ // The TDIL spec says that consonant + virama + RRA should produce a rakar in Malayalam. However,
++ // it seems that almost none of the fonts for Malayalam are set up to handle this.
++ // So, we're going to force the issue here by using the rakar as defined with RA in most fonts.
++
++ if (fPreBaseConsonant == 0x0d31) { // RRA
++ fPreBaseConsonant = 0x0d30; // RA
++ }
++
++ if (fPreBaseConsonant != 0) {
++ writeChar(fPreBaseConsonant, fPBCIndex, fPBCFeatures);
++ writeChar(fPreBaseVirama,fPBCIndex-1,fPBCFeatures);
++ }
++ }
++
+ le_int32 getOutputIndex()
+ {
+@@ -723,4 +754,5 @@
+ }
+
++
+ IndicClassTable::CharClass charClass = CC_RESERVED;
+ IndicClassTable::CharClass nextClass = CC_RESERVED;
+@@ -730,7 +762,9 @@
+ le_bool seenVattu = FALSE;
+ le_bool seenBelowBaseForm = FALSE;
++ le_bool seenPreBaseForm = FALSE;
+ le_bool hasNukta = FALSE;
+ le_bool hasBelowBaseForm = FALSE;
+ le_bool hasPostBaseForm = FALSE;
++ le_bool hasPreBaseForm = FALSE;
+
+ if (postBase < markStart && classTable->isNukta(chars[postBase])) {
+@@ -746,12 +780,20 @@
+ hasBelowBaseForm = IndicClassTable::hasBelowBaseForm(charClass) && !hasNukta;
+ hasPostBaseForm = IndicClassTable::hasPostBaseForm(charClass) && !hasNukta;
++ hasPreBaseForm = IndicClassTable::hasPreBaseForm(charClass) && !hasNukta;
+
+ if (IndicClassTable::isConsonant(charClass)) {
+ if (postBaseLimit == 0 || seenVattu ||
+ (baseConsonant > baseLimit && !classTable->isVirama(chars[baseConsonant - 1])) ||
+- !(hasBelowBaseForm || hasPostBaseForm)) {
++ !(hasBelowBaseForm || hasPostBaseForm || hasPreBaseForm)) {
+ break;
+ }
+
++ // Note any pre-base consonants
++ if ( baseConsonant == lastConsonant && lastConsonant > 0 &&
++ hasPreBaseForm && classTable->isVirama(chars[baseConsonant - 1])) {
++ output.notePreBaseConsonant(lastConsonant,chars[lastConsonant],chars[lastConsonant-1],tagArray2);
++ seenPreBaseForm = TRUE;
++
++ }
+ // consonants with nuktas are never vattus
+ seenVattu = IndicClassTable::isVattu(charClass) && !hasNukta;
+@@ -786,10 +828,12 @@
+
+ // write any pre-base consonants
++ output.writePreBaseConsonant();
++
+ le_bool supressVattu = TRUE;
+
+ for (i = baseLimit; i < baseConsonant; i += 1) {
+ LEUnicode ch = chars[i];
+- // Don't put 'blwf' on first consonant.
+- FeatureMask features = (i == baseLimit? tagArray2 : tagArray1);
++ // Don't put 'pstf' or 'blwf' on anything before the base consonant.
++ FeatureMask features = tagArray1 & ~( pstfFeatureMask | blwfFeatureMask );
+
+ charClass = classTable->getCharClass(ch);
+@@ -842,5 +886,5 @@
+
+ // write below-base consonants
+- if (baseConsonant != lastConsonant) {
++ if (baseConsonant != lastConsonant && !seenPreBaseForm) {
+ for (i = bcSpan + 1; i < postBase; i += 1) {
+ output.writeChar(chars[i], i, tagArray1);
+@@ -872,5 +916,5 @@
+ // write post-base consonants
+ // FIXME: does this put the right tags on post-base consonants?
+- if (baseConsonant != lastConsonant) {
++ if (baseConsonant != lastConsonant && !seenPreBaseForm) {
+ if (postBase <= lastConsonant) {
+ for (i = postBase; i <= lastConsonant; i += 1) {
diff --git a/syncterm/PKGBUILD b/syncterm/PKGBUILD
new file mode 100644
index 0000000..43b8442
--- /dev/null
+++ b/syncterm/PKGBUILD
@@ -0,0 +1,20 @@
+#Maintained by Mattias Andrée <maandree@operamail.com>
+pkgname=syncterm
+pkgver=0.9.5b
+pkgrel=1
+pkgdesc="A BBS terminal program."
+url="http://syncterm.bbsdev.net"
+license='GPL'
+depends=('ncurses')
+options=(!buildflags)
+arch=('i686' 'x86_64')
+source=(http://syncterm.bbsdev.net/syncterm-src.tgz)
+md5sums=('7225918037976da8550490676165c9d0')
+
+build() {
+ cd "$srcdir/syncterm-"*
+ cd "src/syncterm/"
+ make PREFIX="/usr"
+ make PREFIX="$pkgdir/usr" install
+}
+
diff --git a/xz-java-git/PKGBUILD b/xz-java-git/PKGBUILD
index 5dd26fc..88dbed7 100644
--- a/xz-java-git/PKGBUILD
+++ b/xz-java-git/PKGBUILD
@@ -1,15 +1,7 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
-# for more information on packaging from GIT sources.
-
-# Maintainer: Mattias Andrée <maandree@operamail.com>
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=xz-java-git
-pkgver=20120706
-pkgrel=2
+pkgver=20130129
+pkgrel=1
pkgdesc="Java library for XZ and LZMA compression"
arch=('any')
url="http://tukaani.org/xz/java.html"
diff --git a/xz-java/PKGBUILD b/xz-java/PKGBUILD
index cd4d276..8cc84b6 100644
--- a/xz-java/PKGBUILD
+++ b/xz-java/PKGBUILD
@@ -1,21 +1,20 @@
-# Maintainer: Mattias Andrée <maandree@operamail.com>
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=xz-java
-pkgver=1.1
+pkgver=1.2
pkgrel=1
pkgdesc="Java library for XZ and LZMA compression"
arch=('any')
url="http://tukaani.org/xz/java.html"
license=('Public Domain')
depends=('java-runtime>=1.4')
-makedepends=('java-environment>=1.4')
+makedepends=('java-environment>=1.4', 'unzip')
provides=('xz-java')
conflicts=('xz-java')
-source=(xz-java-1.1.tar.xz)
-md5sums=(dd4bdf088177b10c3bcb44efae05ad68)
+source=(http://tukaani.org/xz/xz-java-1.2.zip)
+md5sums=(886e9a03d6077712e2c324e1555bd1ec)
build() {
cd "$srcdir"
-
javac -source 1.4 -target 1.4 -d . -s src -cp . $(find src | grep \\.java\$)
jar -cf xz-java.jar $(find . | grep \\.class\$)
}
diff --git a/xz-java/xz-java-1.1.tar.xz b/xz-java/xz-java-1.1.tar.xz
deleted file mode 100644
index a9fa62b..0000000
--- a/xz-java/xz-java-1.1.tar.xz
+++ /dev/null
Binary files differ