aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sshcd/PKGBUILD19
-rwxr-xr-xsshcd/watch21
2 files changed, 40 insertions, 0 deletions
diff --git a/sshcd/PKGBUILD b/sshcd/PKGBUILD
new file mode 100644
index 0000000..f0cfff0
--- /dev/null
+++ b/sshcd/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=sshcd
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="ssh command with directory specification support"
+arch=(any)
+url="https://github.com/christianbundy/sshcd"
+license=(MIT)
+depends=(openssh bash)
+makedepends=()
+source=(https://github.com/christianbundy/sshcd/archive/v${pkgver}.tar.gz)
+sha256sums=(166edd9975678f2879bf10ebd334d6331d0fe4236be1ddbbeb10f99df858c332)
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+}
+
diff --git a/sshcd/watch b/sshcd/watch
new file mode 100755
index 0000000..3d44674
--- /dev/null
+++ b/sshcd/watch
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+[ -f sshcd ] && rm sshcd
+
+wget 'https://github.com/christianbundy/sshcd/releases' -O sshcd >/dev/null 2>/dev/null
+
+if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
+ grep -Po 'href="[^"]*\.tar\.gz"' < sshcd | md5sum > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'sshcd'
+ fi
+elif [ ! -f unfetchable ]; then
+ touch unfetchable
+ echo 'sshcd (unfetchable)'
+fi
+