aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--qtchess/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/qtchess/PKGBUILD b/qtchess/PKGBUILD
new file mode 100644
index 0000000..b5f27c1
--- /dev/null
+++ b/qtchess/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=qtchess
+pkgver=3.18
+pkgrel=1
+pkgdesc='Online chess game client written in Qt'
+url='http://qtchess.sourceforge.net/'
+arch=('i686' 'x86_64')
+license=('custom:3-clause BSD')
+# (license notice included in qtchess_main.cc)
+depends=('qt5-base' 'libgl')
+makedepends=('qt5-base' 'libgl' 'qt5-tools')
+source=("http://downloads.sourceforge.net/project/qtchess/Version%20${pkgver}/QtChess.d.tar.gz")
+sha256sums=('9a935720018418190c1933013cc47d390fe1f22aa052d308077f561e9a62e84a')
+
+
+build()
+{
+ cd "$srcdir/qtchess.d"
+ qmake-qt5 -o Makefile qtchess.pro
+ sed -i s_'-Werror'__g Makefile # stack protector is not proctecting small arrays
+ make
+}
+
+package()
+{
+ cd "$srcdir/qtchess.d"
+ install -Dm755 QtChess -- "${pkgdir}/usr/bin/qtchess"
+}
+