aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--autohaltd/PKGBUILD28
-rw-r--r--autohaltd/autohaltd.install20
l---------autohaltd/upload1
3 files changed, 49 insertions, 0 deletions
diff --git a/autohaltd/PKGBUILD b/autohaltd/PKGBUILD
new file mode 100644
index 0000000..551f5d8
--- /dev/null
+++ b/autohaltd/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=autohaltd
+pkgver=0.1
+pkgrel=1
+pkgdesc="Bring the system down when it is inactive"
+arch=(i686 x86_64)
+url="https://github.com/maandree/autohaltd"
+license=('GPL3' 'custom:GFDL1.3')
+depends=(sysvinit glibc)
+makedepends=(glibc make coreutils gcc 'texinfo>=4.11')
+install=$pkgname.install
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(2e65913cc190b178ecf621c1a26a1c289180ffa6fd755b70a39d1fc08d09b5f0)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ env -u DEBUG ./configure --prefix=/usr --sbindir=/usr/bin --libexecdir=/usr/lib
+ make
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install DESTDIR="$pkgdir"
+}
+
diff --git a/autohaltd/autohaltd.install b/autohaltd/autohaltd.install
new file mode 100644
index 0000000..32380a9
--- /dev/null
+++ b/autohaltd/autohaltd.install
@@ -0,0 +1,20 @@
+_file="autohaltd"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
diff --git a/autohaltd/upload b/autohaltd/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/autohaltd/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file