aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore7
-rw-r--r--python2-numpydoc/PKGBUILD27
-rwxr-xr-xpython2-numpydoc/watch17
3 files changed, 51 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index 0fdaf94..29f98d3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,6 +7,13 @@
*.bak
*.gz
+*.xz
+*.bz2
+*.sig
+*.asc
sum
src/
pkg/
+*.new
+*.old
+*.diff
diff --git a/python2-numpydoc/PKGBUILD b/python2-numpydoc/PKGBUILD
new file mode 100644
index 0000000..18960ac
--- /dev/null
+++ b/python2-numpydoc/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mattias Andrée <maandree@operamail.com>
+pkgname=python2-numpydoc
+pkgver=0.4
+pkgrel=1
+pkgdesc="Sphinx extension to support docstrings in Numpy format"
+arch=('any')
+url="http://projects.scipy.org/numpy/browser/trunk/doc/sphinxext"
+license=('BSD')
+depends=('python2' 'python2-sphinx')
+conflicts=(python-numpydoc)
+backup=()
+options=(!emptydirs)
+install=
+source=(http://pypi.python.org/packages/source/n/numpydoc/numpydoc-$pkgver.tar.gz)
+md5sums=('e5bdd98f84f2bb220373819e20c27091')
+
+build() {
+
+ cd "$srcdir/numpydoc-$pkgver"
+
+ python2 setup.py install --root=$pkgdir/ --optimize=1 || return 1
+
+ install -D -m644 "$srcdir/numpydoc-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ chmod 644 "$pkgdir"/usr/lib/python*/site-packages/numpydoc-$pkgver-py*.egg-info/*
+
+}
diff --git a/python2-numpydoc/watch b/python2-numpydoc/watch
new file mode 100755
index 0000000..a7dace9
--- /dev/null
+++ b/python2-numpydoc/watch
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+wget http://pypi.python.org/packages/source/n/numpydoc/ >/dev/null 2>/dev/null
+if [ $? = 0 ]; then
+ grep numpydoc- < index.html | md5sum > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'python2-numpydoc'
+ fi
+ rm index.html
+else
+ echo 'python2-numpydoc (unfetchable)'
+fi
+