aboutsummaryrefslogtreecommitdiffstats
path: root/texlive-flashcards/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2013-03-05 07:42:05 +0100
committerMattias Andrée <maandree@operamail.com>2013-03-05 07:42:05 +0100
commitc5840eae508cec504192d2ff0909af1fc58b5e52 (patch)
treed5a6ec4c5dd4f99518712e2025a05ae34e43719a /texlive-flashcards/PKGBUILD
parentadopt emacs-find-recursive (diff)
downloadaur-packages-c5840eae508cec504192d2ff0909af1fc58b5e52.tar.gz
aur-packages-c5840eae508cec504192d2ff0909af1fc58b5e52.tar.bz2
aur-packages-c5840eae508cec504192d2ff0909af1fc58b5e52.tar.xz
adopt texlive-flashcards
Signed-off-by: Mattias Andrée <maandree@operamail.com>
Diffstat (limited to 'texlive-flashcards/PKGBUILD')
-rw-r--r--texlive-flashcards/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/texlive-flashcards/PKGBUILD b/texlive-flashcards/PKGBUILD
new file mode 100644
index 0000000..f4482d3
--- /dev/null
+++ b/texlive-flashcards/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Contributor: tze <tze@datalove.me>
+pkgname=texlive-flashcards
+pkgver=1.0.1
+pkgrel=1
+license=('GPL')
+depends=('texlive-core')
+pkgdesc="A class for typesetting flashcards."
+url="http://ctan.org/pkg/flashcards"
+arch=('any')
+install=texlive-flashcards.install
+source=(http://mirror.ctan.org/macros/latex/contrib/flashcards.zip)
+md5sums=('21f85c9b291a0d06e815ce09d89f4463')
+
+build()
+{
+ mkdir -p $pkgdir/usr/share/texmf/tex/latex/flashcards
+
+ cd $srcdir/flashcards
+ latex flashcards.ins
+ cp flashcards.cls $pkgdir/usr/share/texmf/tex/latex/flashcards
+ cp *.cfg $pkgdir/usr/share/texmf/tex/latex/flashcards
+
+ install -D $srcdir/flashcards/COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}