aboutsummaryrefslogtreecommitdiffstats
path: root/rotd
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2016-07-08 18:50:23 +0200
committerMattias Andrée <maandree@kth.se>2016-07-08 18:50:23 +0200
commitb2e588e879bc8dde4bbc59b109caeb1898bc0041 (patch)
treefb49a6bb024b11152f1a5743e0c95a5866548dc4 /rotd
parentDisable watch script for disowned package (diff)
downloadaur-packages-b2e588e879bc8dde4bbc59b109caeb1898bc0041.tar.gz
aur-packages-b2e588e879bc8dde4bbc59b109caeb1898bc0041.tar.bz2
aur-packages-b2e588e879bc8dde4bbc59b109caeb1898bc0041.tar.xz
derp
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'rotd')
-rw-r--r--rotd/PKGBUILD30
l---------rotd/upload1
2 files changed, 31 insertions, 0 deletions
diff --git a/rotd/PKGBUILD b/rotd/PKGBUILD
new file mode 100644
index 0000000..65f6cea
--- /dev/null
+++ b/rotd/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=rotd
+pkgver=1.0
+pkgrel=1
+pkgdesc="Generate a paper with important or fun information for the day"
+arch=(any)
+url="https://github.com/maandree/rotd"
+license=('custom:ISC')
+depends=(python3 texlive-bin)
+optdepends=("curl: for leap second announcements"
+ "fortune-mod: for fortune cookies"
+ "gnupg: for gnupg key expiry warnings"
+ "solar-python>=2.5: for solar information")
+makedepends=(make coreutils sed)
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(b0513fd7a33f8a6f4b0f76c4de5132d5afe6b56e50782910bbe3aa045c26a9b7)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr LIBEXECDIR=/usr/lib/$pkgname
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr LIBEXECDIR=/usr/lib/$pkgname install DESTDIR="$pkgdir"
+}
+
diff --git a/rotd/upload b/rotd/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/rotd/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file