aboutsummaryrefslogtreecommitdiffstats
path: root/qtchess
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2021-07-10 21:45:11 +0200
committerMattias Andrée <maandree@kth.se>2021-07-10 21:45:11 +0200
commitaf6ba675d6e8b50ba19aa3bb420fa6e2aec7beb4 (patch)
tree07723529946dc7658ec31383f5e1664b7e5fdd41 /qtchess
parentUpdate libparser (diff)
downloadaur-packages-af6ba675d6e8b50ba19aa3bb420fa6e2aec7beb4.tar.gz
aur-packages-af6ba675d6e8b50ba19aa3bb420fa6e2aec7beb4.tar.bz2
aur-packages-af6ba675d6e8b50ba19aa3bb420fa6e2aec7beb4.tar.xz
Update qtchess
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'qtchess')
-rw-r--r--qtchess/PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/qtchess/PKGBUILD b/qtchess/PKGBUILD
index 2f26ba9..e098a0d 100644
--- a/qtchess/PKGBUILD
+++ b/qtchess/PKGBUILD
@@ -1,30 +1,31 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=qtchess
-pkgver=3.20
+pkgver=2021.03.15
pkgrel=1
pkgdesc='Online chess game client written in Qt'
-url='http://qtchess.sourceforge.net/'
+url='https://textbrowser.github.io/qtchess/'
arch=('i686' 'x86_64')
license=('custom:3-clause BSD')
# (license notice included in qtchess_main.cc)
depends=('qt5-base' 'libgl')
makedepends=('qt5-base' 'libgl' 'qt5-tools')
-source=("http://downloads.sourceforge.net/project/qtchess/Version%20${pkgver}/QtChess.d.tar.gz")
-sha256sums=('9ac063d68dc880363ebedc64f12a01ec2032cebd9c969ed711c0ec8db95db254')
+source=(qtchess-${pkgver}.tar.gz::"https://github.com/textbrowser/qtchess/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('b67e182beca7d203dd07b995a6d4cae752dc42ed76439694e1befe5d6bd5f2be')
build()
{
- cd "$srcdir/qtchess.d"
+ cd "$srcdir/qtchess-${pkgver}"
qmake-qt5 -o Makefile qtchess.pro
+ make
sed -i s_'-Werror'__g Makefile # stack protector is not proctecting small arrays
make
}
package()
{
- cd "$srcdir/qtchess.d"
- install -Dm755 QtChess -- "${pkgdir}/usr/bin/qtchess"
+ cd "$srcdir/qtchess-${pkgver}"
+ mkdir -p -- "${pkgdir}/usr/bin/"
+ cp -- QtChess "${pkgdir}/usr/bin/qtchess"
}
-