aboutsummaryrefslogtreecommitdiffstats
path: root/pylibcoopgamma/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2016-08-21 01:09:43 +0200
committerMattias Andrée <maandree@kth.se>2016-08-21 01:09:43 +0200
commitacc22958a3af10c74175ac0460772dc4cd1a2f10 (patch)
tree1bc35c438656fca7d253c1d7327a2598a7c9ff5c /pylibcoopgamma/PKGBUILD
parentUpdate coopgammad (diff)
downloadaur-packages-acc22958a3af10c74175ac0460772dc4cd1a2f10.tar.gz
aur-packages-acc22958a3af10c74175ac0460772dc4cd1a2f10.tar.bz2
aur-packages-acc22958a3af10c74175ac0460772dc4cd1a2f10.tar.xz
Add pylibcoopgamma
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'pylibcoopgamma/PKGBUILD')
-rw-r--r--pylibcoopgamma/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/pylibcoopgamma/PKGBUILD b/pylibcoopgamma/PKGBUILD
new file mode 100644
index 0000000..fde7ee3
--- /dev/null
+++ b/pylibcoopgamma/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=pylibcoopgamma
+pkgver=1.0
+pkgrel=1
+pkgdesc="Cooperative gamma Python 3 library"
+arch=(i686 x86_64)
+url="https://github.com/maandree/pylibcoopgamma"
+license=('GPL3')
+depends=('python>=3.4' libcoopgamma)
+makedepends=('python>=3.4' libcoopgamma cython general-preprocessor)
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(1346ea34798942e874b09b1fb8633d2304296f3698b42e003ce2bd24e600d02a)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+