aboutsummaryrefslogtreecommitdiffstats
path: root/ponypipe
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2017-01-26 21:13:44 +0100
committerMattias Andrée <maandree@kth.se>2017-01-26 21:13:44 +0100
commit7e22b8ae93687e0494a80526753cc9fe4f52bb9b (patch)
treeaeac9fc1eacb491edb0793ce275fdd625703b7d7 /ponypipe
parentFix gimp-plugin-image-reg (diff)
downloadaur-packages-7e22b8ae93687e0494a80526753cc9fe4f52bb9b.tar.gz
aur-packages-7e22b8ae93687e0494a80526753cc9fe4f52bb9b.tar.bz2
aur-packages-7e22b8ae93687e0494a80526753cc9fe4f52bb9b.tar.xz
Add ponypipe
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'ponypipe')
-rw-r--r--ponypipe/PKGBUILD22
l---------ponypipe/upload1
2 files changed, 23 insertions, 0 deletions
diff --git a/ponypipe/PKGBUILD b/ponypipe/PKGBUILD
new file mode 100644
index 0000000..e157e51
--- /dev/null
+++ b/ponypipe/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+pkgname=ponypipe
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="Ponify and deponify text"
+arch=('any')
+url="https://github.com/maandree/ponypipe"
+license=('Public Domain')
+depends=('java-runtime>=6')
+makedepends=('java-environment>=6' 'bash')
+source=(https://github.com/maandree/ponypipe/archive/${pkgver}.tar.gz)
+sha256sums=(b501091dd54acbbc6cda075805fa20767bfc5955954a59b9ae72e31b88bef687)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -B
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/ponypipe/upload b/ponypipe/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/ponypipe/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file