aboutsummaryrefslogtreecommitdiffstats
path: root/libpassphrase/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2024-09-25 22:40:07 +0200
committerMattias Andrée <maandree@kth.se>2024-09-25 22:40:07 +0200
commit29fa855cdb2b02cb989fdd942382f2c404efbc29 (patch)
treefef3cc6d0ae050c12a08051b7f630ce0a8b2aad2 /libpassphrase/PKGBUILD
parentUpdate e-mail address (diff)
downloadaur-packages-master.tar.gz
aur-packages-master.tar.bz2
aur-packages-master.tar.xz
add packagesHEADmaster
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'libpassphrase/PKGBUILD')
-rw-r--r--libpassphrase/PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/libpassphrase/PKGBUILD b/libpassphrase/PKGBUILD
new file mode 100644
index 0000000..c41588f
--- /dev/null
+++ b/libpassphrase/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWF0dGlhcy5hbmRyZWU)@protonmail.com>
+
+pkgname=libpassphrase
+pkgver=1449331105
+pkgrel=1
+pkgdesc="Personalisable library for TTY passphrase reading"
+url="https://github.com/GNU-Pony/libpassphrase"
+arch=(i686 x86_64 armv6h)
+license=(GPL3)
+depends=(glibc)
+makedepends=(make coreutils gcc texinfo)
+optdepends=('passcheck: for strength meter')
+install=libpassphrase.install
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(76044a7af93dd6a956c6fb9a13af711a2c90b260420a2bf1b272d624deefafb7)
+
+
+build() {
+ cd "${srcdir}/libpassphrase-${pkgver}"
+
+ options=()
+ #options+=( PASSPHRASE_ECHO ) # Do not hide the passphrase
+ #options+=( PASSPHRASE_STAR ) # Use '*' for each character instead of no echo
+ options+=( PASSPHRASE_TEXT ) # Use '(empty)' and not '(not empty)' instead of no echo
+ #options+=( PASSPHRASE_REALLOC ) # Soften security by using `realloc`
+ options+=( PASSPHRASE_MOVE ) # Enable move of point
+ options+=( PASSPHRASE_INSERT ) # Enable insert mode
+ options+=( PASSPHRASE_OVERRIDE ) # Enable override mode
+ options+=( PASSPHRASE_DELETE ) # Enable reversed erase command
+ options+=( PASSPHRASE_CONTROL ) # Enable use of control key combinations
+ options+=( PASSPHRASE_DEDICATED ) # Enable use of dedicated keys
+ options+=( DEFAULT_INSERT ) # Use insert mode as default
+ options+=( PASSPHRASE_INVALID ) # Prevent duplication of non-initialised memory
+ options+=( PASSPHRASE_METER ) # Enable strength meter for new passphrases
+ ## see `info '(libpassphrase)' configuring` for details
+
+ star_char="*"
+ text_empty="(empty)"
+ text_not_empty="(not empty)"
+ text_strength="Strength:"
+
+ make PKGNAME="${pkgname}" OPTIONS="${options[*]}" \
+ PASSPHRASE_STAR_CHAR="${star_char}" \
+ PASSPHRASE_TEXT_EMPTY="${text_empty}" \
+ PASSPHRASE_TEXT_NOT_EMPTY="${text_not_empty}" \
+ PASSPHRASE_TEXT_STRENGTH="${text_strength}"
+ ## it is also possible to add PASSPHRASE_STRENGTH_LIMITS_HEADER
+}
+
+package() {
+ cd "${srcdir}/libpassphrase-${pkgver}"
+
+ make PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install
+
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+