aboutsummaryrefslogtreecommitdiffstats
path: root/libkeccak-musl
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2022-02-16 12:22:20 +0100
committerMattias Andrée <maandree@kth.se>2022-02-16 12:22:20 +0100
commitef9dd3a8c9bf58ffccfe2d593bc670d0f0289248 (patch)
tree9f22357093fc8d8a8fca0b3aa3c8b40d715a97b1 /libkeccak-musl
parentAdd libblake, libar2, and libar2simplified (diff)
downloadaur-packages-ef9dd3a8c9bf58ffccfe2d593bc670d0f0289248.tar.gz
aur-packages-ef9dd3a8c9bf58ffccfe2d593bc670d0f0289248.tar.bz2
aur-packages-ef9dd3a8c9bf58ffccfe2d593bc670d0f0289248.tar.xz
Add libkeccka-musl
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'libkeccak-musl')
-rw-r--r--libkeccak-musl/PKGBUILD30
l---------libkeccak-musl/upload1
2 files changed, 31 insertions, 0 deletions
diff --git a/libkeccak-musl/PKGBUILD b/libkeccak-musl/PKGBUILD
new file mode 100644
index 0000000..273be5f
--- /dev/null
+++ b/libkeccak-musl/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+
+pkgname=libkeccak-musl
+_pkgname=libkeccak
+pkgver=1.3.1
+pkgrel=1
+pkgdesc='Keccak-family hashing library'
+arch=('x86_64' 'i686')
+url='https://github.com/maandree/libkeccak'
+license=('custom:ISC')
+_compiler=gcc
+depends=('glibc' 'musl' "${_compiler}")
+source=("${url}/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+b2sums=('cbd8466a8be32db633aadcc1cdfd7c09eedd0606d274d0f5e43b0055a5f87672c1ba27052fd03423779b84648379f0095310d8367cef2ed7ba70d49a66e03249')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+ sed -i 's#FLAGS\s\+=#FLAGS +=#g' optimised.mk
+}
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ make CONFIGFILE=optimised.mk PREFIX=/usr/lib/musl CC="musl-${_compiler}"
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make CONFIGFILE=optimised.mk PREFIX=/usr/lib/musl DESTDIR="${pkgdir}" install
+ rm -r -- "${pkgdir}/usr/lib/musl/share"
+}
diff --git a/libkeccak-musl/upload b/libkeccak-musl/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/libkeccak-musl/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file