aboutsummaryrefslogtreecommitdiffstats
path: root/key2root
diff options
context:
space:
mode:
authorMattias Andrée <m@maandree.se>2024-10-09 21:03:55 +0200
committerMattias Andrée <m@maandree.se>2024-10-09 21:03:55 +0200
commit6875a988c593ec0b069600fc15fef057ed1cc2ba (patch)
treec3c44aa12e5b17072aedfc0531632051f07239b6 /key2root
parentxcman: add missing maintainer line (diff)
downloadaur-packages-6875a988c593ec0b069600fc15fef057ed1cc2ba.tar.gz
aur-packages-6875a988c593ec0b069600fc15fef057ed1cc2ba.tar.bz2
aur-packages-6875a988c593ec0b069600fc15fef057ed1cc2ba.tar.xz
Update misc packages
Signed-off-by: Mattias Andrée <m@maandree.se>
Diffstat (limited to 'key2root')
-rw-r--r--key2root/PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/key2root/PKGBUILD b/key2root/PKGBUILD
index 99dd56c..8d0ecc4 100644
--- a/key2root/PKGBUILD
+++ b/key2root/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Mattias Andrée <m@`base64 -d`(bWFhbmRyZWU).se>
pkgname=key2root
-pkgver=1.0
-pkgrel=2
+pkgver=1.0.1
+pkgrel=1
pkgdesc="Authenticate with keyfile and run a process as root"
arch=('x86_64')
-url="https://maandree.se/proj/key2root.html"
+url="https://codeberg.org/maandree/key2root"
license=('custom:ISC')
depends=('libar2simplified>=1.1.2' libar2 libblake)
-source=($pkgname-$pkgver.tar.gz::https://git.maandree.se/$pkgname/snapshot/$pkgname-$pkgver.tar.gz)
-sha256sums=(c365a009daf784398a0d93b0875a263a078cbc8f417c9e262bd83bab57b0a19e)
+source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha256sums=(c67cd9e9396424b0774412d7620b743a8ecc0ba7c467babf8d7c9dea5150b0a4)
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir/" PREFIX=/usr
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir/" PREFIX=/usr install
}