aboutsummaryrefslogtreecommitdiffstats
path: root/featherweight/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2024-09-25 22:40:07 +0200
committerMattias Andrée <maandree@kth.se>2024-09-25 22:40:07 +0200
commit29fa855cdb2b02cb989fdd942382f2c404efbc29 (patch)
treefef3cc6d0ae050c12a08051b7f630ce0a8b2aad2 /featherweight/PKGBUILD
parentUpdate e-mail address (diff)
downloadaur-packages-master.tar.gz
aur-packages-master.tar.bz2
aur-packages-master.tar.xz
add packagesHEADmaster
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to '')
-rw-r--r--featherweight/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/featherweight/PKGBUILD b/featherweight/PKGBUILD
new file mode 100644
index 0000000..63daa50
--- /dev/null
+++ b/featherweight/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWF0dGlhcy5hbmRyZWU)@protonmail.com>
+
+pkgname=featherweight
+pkgver=1428444876
+pkgrel=2
+pkgdesc="A lightweight news syndication aggregator for your terminal shell"
+url="https://github.com/GNU-Pony/featherweight"
+arch=(any)
+license=(GPL3)
+depends=(python3 coreutils wget pytagomacs html2text-with-utf8)
+makedepends=(make coreutils python3 zip texinfo)
+install=featherweight.install
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(17e8031bec3a68171acc182d925a684b53a2f28c9275362b5592510c07fe2c3b)
+
+
+build() {
+ cd "${srcdir}/featherweight-${pkgver}"
+ make PREFIX=/usr PY_MAJOR=3 PY_MINOR=4
+}
+
+package() {
+ cd "${srcdir}/featherweight-${pkgver}"
+ make PREFIX=/usr PY_MAJOR=3 PY_MINOR=4 DESTDIR="${pkgdir}" install
+
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+