aboutsummaryrefslogtreecommitdiffstats
path: root/emacs-gtk2
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-08-30 22:01:47 +0200
committerMattias Andrée <maandree@operamail.com>2012-08-30 22:01:47 +0200
commitb241d45b9923616d012cb71a6257bf99781e4c8c (patch)
tree7b7982fd38abfb8b72fbfdd19fbadbab7af972d9 /emacs-gtk2
parentadding xz-java (non-git) (diff)
downloadaur-packages-b241d45b9923616d012cb71a6257bf99781e4c8c.tar.gz
aur-packages-b241d45b9923616d012cb71a6257bf99781e4c8c.tar.bz2
aur-packages-b241d45b9923616d012cb71a6257bf99781e4c8c.tar.xz
Saving the world with GTK2 configuration of GNU Emacs
Diffstat (limited to 'emacs-gtk2')
-rw-r--r--emacs-gtk2/PKGBUILD41
-rw-r--r--emacs-gtk2/emacs-gtk2.install32
2 files changed, 73 insertions, 0 deletions
diff --git a/emacs-gtk2/PKGBUILD b/emacs-gtk2/PKGBUILD
new file mode 100644
index 0000000..f787add
--- /dev/null
+++ b/emacs-gtk2/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=emacs-gtk2
+pkgver=24.2
+pkgrel=2
+pkgdesc="The extensible, customizable, self-documenting real-time display editor. GTK2 version"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/emacs/emacs.html"
+license=('GPL3')
+depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk2' 'hicolor-icon-theme' 'gconf' 'desktop-file-utils' 'alsa-lib' 'imagemagick')
+install=emacs-gtk2.install
+source=(ftp://ftp.gnu.org/gnu/emacs/emacs-$pkgver.tar.bz2{,.sig})
+md5sums=('1676803a50e8adc817fdaaebb9234f14' 'ca1766337f419ef827dd96d1ff78f158')
+provides=('emacs')
+conflicts=('emacs')
+
+
+build() {
+ cd "$srcdir"/emacs-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var --with-x-toolkit=gtk --with-xft
+ make
+}
+
+package() {
+ cd "$srcdir"/emacs-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ # remove conflict with ctags package
+ mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
+
+ # fix all the 777 perms on directories
+ find "$pkgdir"/usr/share/emacs/$_majorver -type d -exec chmod 755 {} \;
+
+ # fix user/root permissions on usr/share files
+ find "$pkgdir"/usr/share/emacs/$_majorver -exec chown root:root {} \;
+
+ # fix perms on /var/games
+ chmod 775 "$pkgdir"/var/games
+ chmod 775 "$pkgdir"/var/games/emacs
+ chmod 664 "$pkgdir"/var/games/emacs/*
+ chown -R root:games "$pkgdir"/var/games
+}
diff --git a/emacs-gtk2/emacs-gtk2.install b/emacs-gtk2/emacs-gtk2.install
new file mode 100644
index 0000000..d84f1de
--- /dev/null
+++ b/emacs-gtk2/emacs-gtk2.install
@@ -0,0 +1,32 @@
+ICON_PATH=usr/share/icons/hicolor
+INFO_DIR=usr/share/info
+
+INFO_FILES=(ada-mode auth autotype calc ccmode cl dbus dired-x ebrowse
+ede ediff edt efaq eieio eintr elisp emacs emacs-mime epa erc eshell eudc flymake
+forms gnus idlwave info mairix-el message mh-e newsticker nxml-mode
+org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve smtpmail
+speedbar tramp url vip viper widget woman)
+
+post_install() {
+ gtk-update-icon-cache -q -t -f ${ICON_PATH}
+ update-desktop-database -q
+
+ [[ -x usr/bin/install-info ]] || return 0
+ for f in ${INFO_FILES[@]}; do
+ install-info ${INFO_DIR}/$f.gz ${INFO_DIR}/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ gtk-update-icon-cache -q -t -f ${ICON_PATH}
+ update-desktop-database -q
+
+ [[ -x usr/bin/install-info ]] || return 0
+ for f in ${INFO_FILES[@]}; do
+ install-info --delete ${INFO_DIR}/$f.gz ${INFO_DIR}/dir 2> /dev/null
+ done
+}