aboutsummaryrefslogtreecommitdiffstats
path: root/cedilla/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-11-17 08:38:22 +0100
committerMattias Andrée <maandree@operamail.com>2012-11-17 08:38:22 +0100
commit8497bc668c8f21e3c1e98c61bd3aa5c5a40ad715 (patch)
tree5f70c1b33c352d1e76ffa6bf600233da29d63875 /cedilla/PKGBUILD
parentadopt blender-plugin-vectex (diff)
downloadaur-packages-8497bc668c8f21e3c1e98c61bd3aa5c5a40ad715.tar.gz
aur-packages-8497bc668c8f21e3c1e98c61bd3aa5c5a40ad715.tar.bz2
aur-packages-8497bc668c8f21e3c1e98c61bd3aa5c5a40ad715.tar.xz
adopt cedilla
Signed-off-by: Mattias Andrée <maandree@operamail.com>
Diffstat (limited to 'cedilla/PKGBUILD')
-rw-r--r--cedilla/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/cedilla/PKGBUILD b/cedilla/PKGBUILD
new file mode 100644
index 0000000..460f2fd
--- /dev/null
+++ b/cedilla/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
+pkgname=cedilla
+pkgver=0.6
+pkgrel=1
+pkgdesc="a simple text printer that uses Unicode internally"
+arch=(any)
+url="http://www.pps.jussieu.fr/~jch/software/cedilla/"
+license=('GPL')
+groups=()
+depends=(clisp texlive-core)
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(http://www.pps.jussieu.fr/~jch/software/files/$pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums=('007948ffdec8ff4202ec5efff364ea22')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./compile-cedilla
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # the install-cedilla script would not find the man path in fakeroot, so
+ # we need to create the dirs for it
+ source cedilla-config
+ mkdir -p $pkgdir/$MANDIR
+
+ TARGET=$pkgdir ./install-cedilla
+ sed -i -e 's/texmf-tetex/texmf-dist/g' $pkgdir/etc/cedilla-config.lisp
+}
+
+# vim:set ts=2 sw=2 et: