aboutsummaryrefslogtreecommitdiffstats
path: root/bus
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2017-12-11 23:20:19 +0100
committerMattias Andrée <maandree@kth.se>2017-12-11 23:20:19 +0100
commitee73635c6497ad083c596bdbe3d846ca6d2ef70b (patch)
tree42bec6423b79a99c6061d5797ebf6b97994226ca /bus
parentUpdate metar (diff)
downloadaur-packages-ee73635c6497ad083c596bdbe3d846ca6d2ef70b.tar.gz
aur-packages-ee73635c6497ad083c596bdbe3d846ca6d2ef70b.tar.bz2
aur-packages-ee73635c6497ad083c596bdbe3d846ca6d2ef70b.tar.xz
Add bus
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'bus')
-rw-r--r--bus/PKGBUILD23
l---------bus/upload1
2 files changed, 24 insertions, 0 deletions
diff --git a/bus/PKGBUILD b/bus/PKGBUILD
new file mode 100644
index 0000000..88cab6f
--- /dev/null
+++ b/bus/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+
+pkgname=bus
+pkgver=3.1.7
+pkgrel=1
+pkgdesc="A simple daemonless system for broadcasting messages locally"
+arch=(i686 x86_64)
+url="https://github.com/maandree/bus"
+license=('custom:ISC')
+depends=()
+makedepends=()
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=(0f045b016c94e137c44834d37ae59ffef3c91eb6501b3dfbf32468185c86a1c8)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
diff --git a/bus/upload b/bus/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/bus/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file