aboutsummaryrefslogtreecommitdiffstats
path: root/bookshelf/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2016-11-16 23:57:07 +0100
committerMattias Andrée <maandree@kth.se>2016-11-16 23:57:07 +0100
commit217957ca55c5f463c76eeb464f9f5c37389185ff (patch)
tree01c1a94005c0ac8ddcc9bd87975c5d64cb4d2505 /bookshelf/PKGBUILD
parentadd setpgrp (diff)
downloadaur-packages-217957ca55c5f463c76eeb464f9f5c37389185ff.tar.gz
aur-packages-217957ca55c5f463c76eeb464f9f5c37389185ff.tar.bz2
aur-packages-217957ca55c5f463c76eeb464f9f5c37389185ff.tar.xz
add 5 old projects
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'bookshelf/PKGBUILD')
-rw-r--r--bookshelf/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/bookshelf/PKGBUILD b/bookshelf/PKGBUILD
new file mode 100644
index 0000000..3124056
--- /dev/null
+++ b/bookshelf/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=bookshelf
+pkgver=1
+pkgrel=1
+pkgdesc='Virtual bookshelf browser for the terminal'
+arch=(any)
+url='https://github.com/maandree/bookshelf'
+license=(GPL3)
+depends=(bash grep coreutils)
+optdepends=('jfbview: default document viewer under TTY'
+ 'xpdf: default document viewer under X')
+makedepends=(texinfo gzip)
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(cfa0a9f1482533ccc0be068abd9deab716d966b837668dfdca0beba10dfa9493)
+
+
+build() {
+ cd "${srcdir}/bookshelf-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/bookshelf-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+