aboutsummaryrefslogtreecommitdiffstats
path: root/argparser-python
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2016-06-24 14:55:33 +0200
committerMattias Andrée <maandree@kth.se>2016-06-24 14:55:33 +0200
commit72a4f4f2795bb22808229ca7ce1bec1de2823d98 (patch)
treed51a4c91db9db4b2f6c0b1a83c21352dd6c6a47c /argparser-python
parentAdd xpybar (diff)
downloadaur-packages-72a4f4f2795bb22808229ca7ce1bec1de2823d98.tar.gz
aur-packages-72a4f4f2795bb22808229ca7ce1bec1de2823d98.tar.bz2
aur-packages-72a4f4f2795bb22808229ca7ce1bec1de2823d98.tar.xz
Add argparser
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'argparser-python')
-rw-r--r--argparser-python/PKGBUILD26
l---------argparser-python/upload1
2 files changed, 27 insertions, 0 deletions
diff --git a/argparser-python/PKGBUILD b/argparser-python/PKGBUILD
new file mode 100644
index 0000000..11967d2
--- /dev/null
+++ b/argparser-python/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=argparser-python
+pkgver=5.1
+pkgrel=1
+pkgdesc="Command line argument parser library, like getopt, except better. Python version."
+arch=('any')
+url="https://github.com/maandree/argparser"
+license=('AGPL3')
+makedepends=('coreutils' 'sed')
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('10cbff3d7c17d5c8e99dab20e5b425e1da7625dd4090d6c904c944b8bb64195f')
+
+
+build() {
+ cd "${srcdir}/argparser-${pkgver}"
+ make DESTDIR="$pkgdir" PKGNAME="$pkgname" PY3VERSION="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1,2)" \
+ python
+}
+
+package() {
+ cd "${srcdir}/argparser-${pkgver}"
+ make DESTDIR="$pkgdir" PKGNAME="$pkgname" PY3VERSION="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1,2)" \
+ install-python install-license
+}
+
diff --git a/argparser-python/upload b/argparser-python/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/argparser-python/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file