aboutsummaryrefslogtreecommitdiffstats
path: root/applebloom
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2024-09-25 22:40:07 +0200
committerMattias Andrée <maandree@kth.se>2024-09-25 22:40:07 +0200
commit29fa855cdb2b02cb989fdd942382f2c404efbc29 (patch)
treefef3cc6d0ae050c12a08051b7f630ce0a8b2aad2 /applebloom
parentUpdate e-mail address (diff)
downloadaur-packages-master.tar.gz
aur-packages-master.tar.bz2
aur-packages-master.tar.xz
add packagesHEADmaster
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'applebloom')
-rw-r--r--applebloom/PKGBUILD30
-rw-r--r--applebloom/applebloom.install20
l---------applebloom/upload1
3 files changed, 51 insertions, 0 deletions
diff --git a/applebloom/PKGBUILD b/applebloom/PKGBUILD
new file mode 100644
index 0000000..5c9224d
--- /dev/null
+++ b/applebloom/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWF0dGlhcy5hbmRyZWU)@protonmail.com>
+
+pkgname=applebloom
+pkgver=1396811847
+pkgrel=1
+pkgdesc="Apple Bloom the pony dictionary"
+url="https://github.com/GNU-Pony/applebloom"
+arch=(any)
+license=(AGPL3)
+depends=(bash coreutils)
+makedepends=(make coreutils sed texinfo gzip)
+install=applebloom.install
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(899e6cc9ccdb3143158e43b8f0bedcb3babdb89533ad575eb72e339f183cc7bc)
+
+_prefix=/usr
+
+
+build() {
+ cd "${srcdir}/applebloom-${pkgver}"
+ make PREFIX="${_prefix}" PKGNAME="${pkgname}" DESTDIR="${pkgdir}" default
+}
+
+package() {
+ cd "${srcdir}/applebloom-${pkgver}"
+ make PREFIX="${_prefix}" PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install
+ _dir="${pkgdir}${_prefix}/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/AGPL3" "${_dir}/LICENSE"
+}
+
diff --git a/applebloom/applebloom.install b/applebloom/applebloom.install
new file mode 100644
index 0000000..0480eb1
--- /dev/null
+++ b/applebloom/applebloom.install
@@ -0,0 +1,20 @@
+_file="applebloom"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
diff --git a/applebloom/upload b/applebloom/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/applebloom/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file