aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2015-03-15 15:56:30 +0100
committerMattias Andrée <maandree@operamail.com>2015-03-15 15:56:30 +0100
commitbce4422b2f66ed9897ba92fe6d21d68466589f3c (patch)
treea96135341a82c3f76e711c31bc226065d1f3376a
parentadd lib32-libjson (diff)
downloadaur-packages-bce4422b2f66ed9897ba92fe6d21d68466589f3c.tar.gz
aur-packages-bce4422b2f66ed9897ba92fe6d21d68466589f3c.tar.bz2
aur-packages-bce4422b2f66ed9897ba92fe6d21d68466589f3c.tar.xz
update xorg-server-hwcursor-gamma
Signed-off-by: Mattias Andrée <maandree@operamail.com>
-rw-r--r--xorg-server-hwcursor-gamma/0001-int10-Fix-error-check-for-pci_device_map_legacy.patch47
-rw-r--r--xorg-server-hwcursor-gamma/PKGBUILD6
2 files changed, 52 insertions, 1 deletions
diff --git a/xorg-server-hwcursor-gamma/0001-int10-Fix-error-check-for-pci_device_map_legacy.patch b/xorg-server-hwcursor-gamma/0001-int10-Fix-error-check-for-pci_device_map_legacy.patch
new file mode 100644
index 0000000..75e5bb9
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/0001-int10-Fix-error-check-for-pci_device_map_legacy.patch
@@ -0,0 +1,47 @@
+From 0a78b599b34cc8b5fe6fe82f90e90234e8ab7a56 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?J=C3=BCrg=20Billeter?= <j@bitron.ch>
+Date: Sat, 7 Feb 2015 18:13:21 +0100
+Subject: [PATCH] int10: Fix error check for pci_device_map_legacy
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+pci_device_map_legacy returns 0 on success.
+
+Signed-off-by: Jürg Billeter <j@bitron.ch>
+Reviewed-by: Adam Jackson <ajax@redhat.com>
+Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+---
+ hw/xfree86/int10/generic.c | 2 +-
+ hw/xfree86/os-support/linux/int10/linux.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/hw/xfree86/int10/generic.c b/hw/xfree86/int10/generic.c
+index 012d194..8d5c4da 100644
+--- a/hw/xfree86/int10/generic.c
++++ b/hw/xfree86/int10/generic.c
+@@ -104,7 +104,7 @@ readIntVec(struct pci_device *dev, unsigned char *buf, int len)
+ {
+ void *map;
+
+- if (!pci_device_map_legacy(dev, 0, len, 0, &map))
++ if (pci_device_map_legacy(dev, 0, len, 0, &map))
+ return FALSE;
+
+ memcpy(buf, map, len);
+diff --git a/hw/xfree86/os-support/linux/int10/linux.c b/hw/xfree86/os-support/linux/int10/linux.c
+index 79b9a88..6ca118f 100644
+--- a/hw/xfree86/os-support/linux/int10/linux.c
++++ b/hw/xfree86/os-support/linux/int10/linux.c
+@@ -75,7 +75,7 @@ readLegacy(struct pci_device *dev, unsigned char *buf, int base, int len)
+ {
+ void *map;
+
+- if (!pci_device_map_legacy(dev, base, len, 0, &map))
++ if (pci_device_map_legacy(dev, base, len, 0, &map))
+ return FALSE;
+
+ memcpy(buf, map, len);
+--
+2.3.2
+
diff --git a/xorg-server-hwcursor-gamma/PKGBUILD b/xorg-server-hwcursor-gamma/PKGBUILD
index 827edde..111ec84 100644
--- a/xorg-server-hwcursor-gamma/PKGBUILD
+++ b/xorg-server-hwcursor-gamma/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=xorg-server
pkgname=xorg-server-hwcursor-gamma
pkgver=1.17.1
-pkgrel=3
+pkgrel=4
pkgdesc="Xorg X server with patch to apply gamma ramps on hardware cursors"
depends=(libepoxy libxdmcp libxfont libpciaccess libdrm pixman libgcrypt libxau xorg-server-common xf86-input-evdev libxshmfence libgl)
provides=("xorg-server=${pkgver}" 'X-ABI-VIDEODRV_VERSION=19' 'X-ABI-XINPUT_VERSION=21' 'X-ABI-EXTENSION_VERSION=9.0' 'x-server')
@@ -27,6 +27,7 @@ source=(${url}/releases/individual/xserver/${_pkgname}-${pkgver}.tar.bz2
xvfb-run.1
os-access-fix-regression-in-server-interpreted-auth.patch
v2-xserver-Fix-a-crash-with-XDMCP-error-handler.patch
+ 0001-int10-Fix-error-check-for-pci_device_map_legacy.patch
0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch
0002-Fix-for-full-and-semi-transparency-under-negative-im.patch
0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch)
@@ -36,6 +37,7 @@ sha256sums=('2bf8e9f6f0a710dec1d2472467bff1f4e247cb6dcd76eb469aafdc8a2d7db2ab'
'2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776'
'8a9d76eecf8795ca645fb1ce261733965578e953f6606153ce001a0e15d036e8'
'a73e33644682d9f430db987c192da0f7193907af50539669ebd59614a5ebd0f9'
+ '2ea82cdbd695f21c935710847913ed58e22d3d5c0c18c96175a4a6cc1142c071'
'bea348631dedd66475d84ac2cfe0840f22a80a642b4680d73fead4749e47f055'
'be9169b937b5d0b44f7f05d7c08aaa5f0c1092e128ce261d9cb350f09dfe1fb0'
'0a643ae83e03faee0f4db669a33c5b3c99edbba5c86cde2c83962ae536d31081')
@@ -51,6 +53,8 @@ prepare() {
patch -Np1 -i ../os-access-fix-regression-in-server-interpreted-auth.patch
# partially fix FS#43867, not yet upstream
patch -Np1 -i ../v2-xserver-Fix-a-crash-with-XDMCP-error-handler.patch
+ # fix FS#43924, merged upstream
+ patch -Np1 -i ../0001-int10-Fix-error-check-for-pci_device_map_legacy.patch
}
build() {